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INPACKING AND INSTALLATION

Inventory

Use of this kit requires a PC with Windows 95, 98, ME, NT, 2000 or XP. The PC must have
a spare 9-Pin Serial or USB port, a CD-ROM drive and 75 MB of disk space.

The diagram on the following page shows each component in the ACE kit. Ensure every
item is present.
Software

Insert the CD into the computer and wait for the installation program to start. If your computer
is not set up to auto-run CDs, then select My Computer and double-click on the CD drive.

Click on Install and use the default settings for all subsequent prompts by clicking NEXT,
OK, CONTINUE...as required.

Identify a directory to be used for the programs in this booklet. The install program will have
created an empty directory c:\program files\picc\projects that may be used for this purpose.

Select the compiler icon on the desktop. In the PCW IDE, click Help>About and verify
a version number is shown for the IDE and PCM to ensure the software was installed
properly. Exit the software.

Hardware

Place the PIC16F877A into the socket and lower the handle to lock it into place. If the
oscillator is not already installed, install it into the clock header making sure that pin 1 of
the header lines up with pin 1 of the oscillator.

Connect the PC to the ICD(6) using the USB cable.(7) Connect the prototyping board
(9) to the ICD using the modular cable(5). Plug in the DC adaptor (8) to the power socket
and plug it into the prototyping board (9). The first time the ICD-U is connected to the
PC, Windows will detect new hardware. Install the USB driver from the CD or website
using the new hardware wizard. The driver needs to be installed properly before the
device can be used.

The LED should be red® on the ICD to indicate the unit is connected properly.

Run the Programmer Control Software by clicking on the CCSLOAD icon on the desktop.
Use CCSLOAD Help File for assistance.

U The software will auto-detect the programmer and target board and the LED should be
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illuminated green. If any errors are detected, go to Diagnostic tab. If all tests pass, the
hardware is installed properly.

Disconnect the hardware until you are ready for Chapter 3. Always disconnect the power
to the Prototyping board before connecting/disconnecting the ICD or changing the
jumper wires to the Prototyping board.

(M1CS-S40 can also be used in place of ICD-U. Connect it to an available serial port on the PC using the 9
pin serial cable. There is no driver required for S40.

@1CD-U40 units will be dimly illuminated green and may blink while connecting.
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Carrying case

Exercise booklet

CD-ROM of C compiler (optional)

Serial PC to Prototyping board cable
Modular ICD to Prototyping board cable
ICD or Mach X unit for programming and
debugging (optional)

USB or Serial PC to ICD cable

AC Adaptor (12VDC)

Prototyping board with a 40 pin ZIF socket

Experiments Kit:
24L.C16B/P
PIC16F877A Reprogrammable chip
NJUG355ED

(real-time clock chip with 32kHz crystal)
74HC595N
93LC56 Serial EEPROM chip

DS1631 digital thermometer chip
DS1868 dual digital potentiometer chip
DS1982 iButton chip
PCF8570PN I2C chip

Three 1.0K 1/4 W Resistor

4.7K 1/4 W Resistor

Two 15 pf Capacitor

22 pf Capacitor

3.57 mHz crystal

4 mHz Oscillator

10 mHz Oscillator

Two 14 pin headers

Jumper Wire

USB Add-on

2-digit 7-segment LED

@ Breadboard

ACE Kit Exercise Book



CCS, Inc.

ING THE INTEGRATED

uEVELOPMENT ENVIRONMENT (IDE)

Editor
Open the PCW IDE. If any files are open, click File>Close All

Click File>Open>Source File. Select the file: c:\program files\picc\examples\ex_
stwt.c

Scroll down to the bottom of this file. Notice the editor shows comments, preprocessor
directives and C keywords in different colors.

Move the cursor over the Set_timer0 and click. Press the F1 key. Notice a Help file
description for set_timer0 appears. The cursor may be placed on any keyword or built-in
function and F1 will find help for the item.

Review the editor special functions by clicking on Edit. The IDE allows various standard
cut, paste and copy functions.

Review the editor option settings by clicking on Options>Editor Properties. The
IDE allows selection of the tab size, editor colors, fonts, and many more. Click on
Options>Toolbar to select which icons appear on the toolbars.

Compiler

Use the drop-down box under Compile to select the compiler. CCS offers different
compilers for each family of Microchip parts. All the exercises in this booklet are for the
PIC16F877A chip, a 14-bit opcode part. Make sure PCM 14 bit is selected in the white
box under the Compiler tab.

The main program compiled is always shown in the bottom of the IDE. If this is not the
file you want to compile, then click on the tab of the file you want to compile. Right click
into editor and select Make file project.

Click Options>Project Options>Include Files... and review the list of directories
the compiler uses to search for included files. The install program should have put two
directories in this list: devices and drivers.

Normally the file formats need not be changed and global defines are not used in these
exercises. To review these settings, click Options>Project Options>Output Files and
Options>Project Options>Global Defines.

Click the compile icon to compile. Notice the compilation box shows the files created
and the amount of ROM and RAM used by this program. Press any key to remove the
compilation box.



Viewer

U Click Compile>Symbol Map. This file shows how the RAM in the microcontroller
is used. Identifiers that start with @ are compiler generated variables. Notice some
locations are used by more than one item. This is because those variables are not
active at the same time.

U Click Compile>C/ASM List. This file shows the original C code and the assembly
code generated for the C. Scroll down to the line:
int count=INTS PER SECOND;

U Notice there are two assembly instructions generated. The first loads 4C into the W
register. INTS_PER_SECOND is #defined in the file to 76. 4C hex is 76 decimal.
The second instruction moves W into memory. Switch to the Symbol Map to find the
memory location where int_count is located.

O Click View>Data Sheet, then View. This brings up the Microchip data sheet for the
microprocessor being used in the current project.

Click here for the file menu. Files and Projects are created,

. . Place cursor over each icon
opened, or closed using this menu.

and press F1 for help.

Compiles current selected unit, does NOT link/build

into a HEX file.
Click the help icon for
Compiles all units that have changed since last build, the help menu. The technical
links/builds into a HEX file. support wizard and download

Compiles all units regardless if they have changed since manager are accessed using
last build, links/builds into a HEX file. this menu.

N~

Compile ribbon.

Place cursor here for slide out boxes.
All of the current project’s source and =
output files can be seen here.

B
- wr inkd ™iakrLocwt Lo "
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OMPILING AND
UNNING A PROGRAM

Open the PCW IDE. If any files are open, click File>Close All
Click File>New>Source File and enter the filename EX3.C

Type in the following program and Compile.

('#include <16£f877A.h>
f#device ICD=TRUE
#fuses HS, NOLVP, NOWDT, PUT
#use delay (clock=20000000)

#define FIRST LED PIN A5

void main () {
while (TRUE) {
output low (FIRST LED);
delay ms (1000) ;
output high (FIRST LED) ;
delay ms (1000) ;

Run a jumper wire from PIN 20 to PIN 42 on the terminal strip.

' ® The first four lines of this program define the basic hardware
environment. The chip being used is the PIC16F877A, running at
20MHz with the ICD debugger.

® The #define is used to enhance readability by referring to
GREEN_LED in the program instead of PIN_AS5.

® The “while (TRUE)” is a simple way to create a loop that never stops.

® Note that the “output_low” turns the LED on because the other end of
the LED is +5V. This is done because the chip can tolerate more
current when a pin is low than when it is high.

NOTES

® The “delay_ms(1000)” is a one second delay (1000 milliseconds).




Connect the ICD to the Prototyping board using the modular cable, and connect the
ICD to the PC. Power up the Prototyping board.

Click Debug>Enable Debugger and wait for the program to load.

Click the green go icon:

Expect the debugger window status block to turn yellow indicating the program is running.

The first LED on the Prototyping board should be flashing between green and red. One
second green and one second red.

The program can be stopped by clicking on the stop icon: ﬂ

0 oo O

FURTHER STUDY .

A Modify the program to light the first LED for 5 seconds, then the second for
1 second and the third for 5 seconds.
Be sure to place a jumper from the LED to the desired output port.
Example: pin B4(51) to LED2(43)
pin B5(52) to LED3(44)
B Add to the program a #define macro called “delay _seconds” so the
delay ms(1000) can be replaced with : delay seconds(1); and
delay _ms(5000) can be: delay _seconds(5);.

Note: Name these new programs EX3A.c and EX3B.c and follow the same
naming convention throughout this booklet.
For the remaining of the exercises all needed jumper wires will be listed
under a heading titled "Jumpers."
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IANDLING INPUT

O Type in the following program, named EX4.C, Compile and Run:

/V#include <16£877A.h>

#device ICD=TRUE
#fuses HS,NOLVP,NOWDT, PUT
#use delay(clock=20000000)

#define FIRST LED PIN A5

#define SECOND LED PIN B4

#define THIRD LED PIN B5

#define PUSH BUTTON PIN A4

//

void light one led(int led) {
Output_high(FIRST_LED);
output high (SECOND LED) ;
output high (THIRD LED) ;

switch(led) {

case 0 : output low(FIRST LED); break;
case 1 : output low (SECOND LED); break;
case 2 : output low(THIRD LED); break;
}

}

wait for one press() {

while (input (PUSH BUTTON)) ;
while(!input(PUSH_BUTTON)) 2
}

void main () {
while (TRUE) {
light one led(0);
wait for one press();
light one led(1);
wait for one press();
light one led(2);
wait for one press();

\_!

O Jumpers: pinA5(20) to LED1(42)
pinB4(51) to LED2(43)
pinB5(52) to LED3(44)
pinA4(19) to switch1(40)

U As can be seen from the program, the first LED should come on. Press the button
and the second LED should light and then the third LED when pressed again. Add the
following new type below the // lines:

typedef enum {FIRST,SECOND,THIRD} LEDS;

CCS, Inc.



U Change the parameter to light_one_led to leds instead of int.
U Change the 0, 1, 2 in the call to FIRST, SECOND, THIRD.

® The Prototyping board has one momentary pushbutton that may be
used as an input to the program. The input pin is connected to a 10K
pull-up resistor to +5V. The button, when pressed, shorts the input pin
to ground. The pin is normally high while in this configuration, but it is
low while the button is pressed.

This program shows how to use simple C functions. The function
wait_for_one_press() will first get stuck in a loop while the input pin

is high (not pressed). It then waits in another loop while the pin is low.
The function returns as soon as the pin goes high again. Note that
the loops, since they do not do anything while waiting, do not look like
much-they are a simple ; (do nothing).

m ® \When the button is pressed once, it is common for several very quick

LU connect disconnect cycles to occur. This can cause the LEDs to

h advance more than once for each press. A simple debounce

° algorithm can fix the problem. Add the following line between the two
while loops: delay_ms(100); The following scope picture of a button

z press depicts the problem:

T — : e SR B B R L

e ra—
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e

FURTHER STUDY .

A Modify the program so that while the button is held down the LEDs alternate
as fast as possible. When the button is not pressed the LED state freezes.
This creates a random color program.
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I’ROGRAM STRUCTURE

It is good practice to put all the hardware definitions for a given design into a common
file that can be reused by all programs for that board. Open EX4.C and highlight the first
nine lines of the file. Click Edit>Paste to file and give it the name prototype.h.

It is also helpful to collect a library of utility functions to use as needed for future programs.
Note that just because a function is part of a program does not mean it takes up memory.
The compiler deletes functions that are not used. Highlight the wait_for_one_press()
function, light_one_led function and the typedef line (if added from Chapter 4 Notes
section) and save that to a file named utility.c. Open utility.c and add the following new
function to the file:

-

void show binary on leds(int n) {
output high (FIRST LED) ;
output high (SECOND LED) ;
output high (THIRD LED) ;
if( bit test(n,0) )
output low (FIRST LED);
if( bit test(n,1) )
output low (SECOND LED) ;
if( bit test(n,2) )
output low (THIRD LED) ;

U Y,

Close all files and start a new file named EX5.C as follows:

('#include <prototype.h> )
#include <utility.c>

main () {
int count = 0;

while (TRUE) {
show binary on leds(count) ;
wait for one press();
count++;

\ Y,

Jumpers: pinA5(20) to LED1(42)
pinB4(51) to LED2(43)
pinB5(52) to LED3(44)
pinA4(19) to switch1(40)



U Compile and Run the

program. Check that ettt ettt
with each button press, Poeceecceccccccsosoccoccsce
theLEDs|ncrement|n OOO © © 0000 00000 0000 000 000 |
a binary number 0-7 as o o0 o 5 — - e’
shown here. 10 0—— 1 \-.
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® In C, a function must either appear in the input stream before it is used
OR it must have a prototype. A prototype is the part of the function
definition before the “{“. In a program where main calls function A and
function A calls function B, the order in the file must be B, A, MAIN.
As an alternative, have Ap, Bp, MAIN, A, B where Ap and Bp are
prototypes. Frequently, prototypes are put into a header file with a .h
extension.

® The scope, initialization, and life of C variables depend on where and
how they are declared. The following is a non-inclusive summary of the
common variable scopes. Note that if a variable has an initialization (like
int a=1;) the assignment happens each time the variable comes to life.

" NOTES |

Where it is defined

Can be accessed

Life of the variable

Inside a function

Only in that function

While function is alive

Inside a function with
STATIC

Only in that function

During the entire run of
the program

Outside all functions

In any function defined
afterwards in the file

During the entire run of
the program

After “{“ inside a
function

Only between the “{*
and corresponding “}’

Only up to the
corresponding “}”

FURTHER STUDY

Modify the program to increment the binary number 1 every second
(the button is not used).

(such as & and ==) to test the bits.

Instead of the built-in function BIT _TEST use the standard C operators

ACE Kit Exercise Book
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.UGGING

Open EX5.C and start the debugger Debug>Enable Debugger.
Click the reset icon to ensure the target is ready.

Click the step-over icon 5“‘\1' twice. This is the step over command. Each click causes a
line of C code to be executed. The highlighted line has not been executed, but the line
about to be executed.

Step over the show binary on leds(count); line and notice that one click
executed the entire function. This is the way step over works. Click step over on
wait for one press/();.Press the prototype button and notice the debugger
now stops since the function terminates.

Click the Watch tab, then the add icon :] to add a watch. Enter count or choose
count the variables from list, then click Add Watch. Notice the value shown. Continue
to step over through the loop a few more times (press the button as required) and notice
the count watch increments.

Step over until the call to show binary on leds(count); is highlighted. This
time, instead of step over, use the standard | step icon 1 several times and notice the
debugger is now stepping into the function.

Click the GO icon @ to allow the program to run. Press the prototype button a couple
of times to verify that the program is running normally. Click the stop icon 9 to halt
execution. Notice the C source line that the program stopped on. This is the line were the
program is waiting for a button press.

In the editor, click on show binary on leds(count); to move the editor cursor
to that line. Then click the Breaks tab and click the add icon :] to set a breakpoint. The
debugger will now stop every time that line is reached in the code. Click the GO icon

and then press the prototype button. The debugger should now stop on the breakpoint.
Repeat this a couple of times to see how the breakpoint works.

Click Compile>C/ASM list. Scroll down to the highlighted line. Notice that one assembly

instruction was already executed for the next line. This is another side effect of the ICD-S
debugger. Sometimes breakpoints slip by one ASM instruction.

Click the step over icon a few times and note that when the list file is the selected
window, the debugger has executed one assembly instruction per click instead of one
entire C line.

Close all files and start a new file EX6.C as follows:



(V#include <prototype.h>
finclude <utility.c>

void main () {
int a,b,c;

a=11;

b=5;

c=a+tb;

c=b-a;

while (TRUE) ;
N J

U Compile the program and step-over until the c=a+b is executed. Add a watch for ¢ and
the expected value is 16.

U Step-over the subtraction and notice the value of c. The int data type by default is
not signed, so ¢ cannot be the expected —6. The modular arithmetic works like a car
odometer when the car is in reverse only in binary. For example, 00000001 minus 1 is
00000000, subtract another 1 and you get 11111111.

U Reset and again step up to the c=a+b. Click the Eval tab. This pane allows a one time
expression evaluation. Type in a+b and click Eval to see the debugger and calculate the
result. The complete expression may also be put in the watch pane as well. Now enter
b=10 and click Eval. This expression will actually change the value of B if the “keep side
effects” check box of the evaluation tab is checked. Check it and click Eval again. Step
over the addition line and click the Watch tab to observe the c value was calculated with
the new value of b.

FURTHER STUDY .

A Modify the program to include the following C operators to see how they work:
*/ % & N
Then, with b=2 try these operators: >> <<
Finally, try the unary complement operator with: c=~a;

B Design a program to test the results of the relational operators:
< > == /=
by exercising them with b as 10, 11, and 12.
Then, try the logical operators || and && with the four combinations of a=0,1
and b=0,1.
Finally, try the unary not operator with: c=!a; when a is 0 and 1.

ACE Kit Exercise Book



ALOG TO DIGITAL
NVERSION

U The PIC16F877A chip has eight pins that may be used to read an analog voltage. These
eight pins can be configured to certain combinations of analog input and digital pins, but
not all combinations are possible. The following is a simple program (EX7.c) to read one

analog pin.
('#include <prototype.h> )
#include <utility.c>
#define cutoff 128 // 2.5 Volts
#define neutral zone 25 // 0.5 Volts
void main () {
int reading;
setup adc ports( RAO ANALOG ) ;
setup_adc( ADC CLOCK INTERNAL ) ;
set adc channel( 0 );
while (TRUE) {
reading = read adc();
if(reading<(cutoff—neutral_zone/Z))
light one led(FIRST);
else if (reading>(cutoff+neutral_zone/2))
light one 1led(THIRD) ;
else
light one 1led(SECOND) ;
}
N Y

O Jumpers: pinA5(20) to LED1(42)
pinB4(51) to LED2(43)
pinB5(52) to LED3(44)
pinA4(19) to switch1(40)
Analog 9 (9) to A0(15)

U Compile and Run the program. Verify that the Prototyping board knob Analog 9 (9)

jumpered to pin A0(15) is turned so the first LED is on when it is low, the third LED when
high and the second LED for a small region in the center.

eess s scsselvvvviese
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® By default, the analog to digital converter is 8 bits. Thus, a range of
0 to 5 volts analog is represented by the numbers 0-255. The A/D
reading can be converted to volts by the formula:
Volts = reading*(5.0/255)

® The setup_adc_ports function call determines what pins are set to
be analog inputs. The setup_adc function call determines how fast
the conversion is done. The internal clock option uses an internal RC
clock. Although the timing is not exact, it is long enough for an
accurate conversion. The time can be based off the instruction clock
for more precise timing.

v

L

=

o ® The set_adc_channel function sets the A/D converter to channel 0
(ANO or AO). This switches an internal mux in the part, but does not

z start an A/D conversion. Even though a conversion has not started,
there is a small capacitor in the chip that must charge up after the
port switch and before the voltage is read. This is fast with a low
impedance input, but for a higher impedance input, a small delay
should be put in after the channel is changed.

® The call to read_adc starts a conversion, waits for it to complete and
returns the result. The conversion time is around 20us.

FURTHER STUDY .

A Modify the program to use a long variable for reading. Open prototype.h and after:
#device ICD=TRUE
add the following
ADC=10
This will change the range to 0-1023. Change the constant in the program to
reflect the new range.
When the above example is complete, remove the ADC=10 so it will default to
ADC=8

B Write a timer program that will light the first LED for x seconds when pressing the
button. x should be 0-25, depending on the setting of the analog knob.

ACE Kit Exercise Book



RRAYS AND
NALOG FILTERING

U The following EX8.c program illustrates how to change the EX7.c program such that the

value used to light the LED is the average voltage over the previous 10 seconds.

~

}
_

#include <prototype.h>
#include <utility.c>

#define cutoff 128 // 2.5 volts
#define neutral zone 25 // 0.5 Volts
void main () {

int history[10];

int history ptr = 0;

long reading;

int count=0;

int 1i;

setup adc ports( RAO ANALOG ) ;
setup adc ( ADC_CLOCK INTERNAL ) ;
set adc channel ( 0 );

while (TRUE) {
reading=0;
delay ms (1000) ;
historyl[history ptr++] = read adc();
if (history ptr==10) {
history ptr=0;
count = 10;
} else
if (count<10)
count=history ptr;
for (i=0; i<count;i++)
reading += history[i];
reading /= count;
if (reading<(cutoff-neutral zone/2))
light one led(FIRST);
else if (reading>(cutoff+neutral zone/2))
light one led(THIRD);
else
light one led(SECOND) ;

~

O Jumpers: pinA5(20) to LED1(42)

CCS, Inc.

pinB4(51) to LED2(43)
pinB5(52) to LED3(44)
Analog 9(9) to A0(15)



U Run the new program and confirm that the movement of the knob takes 10 seconds to
appear on the LEDs. Furthermore, confirm that a quick movement of the knob from high
to low makes no difference in the LEDs.

This program uses several of the C shortcut operators. For example, the
reading += history[i] isthe same as
reading = reading + history[i]
and history[history ptr++] = read adc(); is the same as
historylhistory ptr] = read adc();

history ptr = history ptr+l;

history[0] through history[9].

® The reading variable needs to be a long (16 bits) because the largest
value 255*10 is larger than 8 bit int.

® The history variable can be placed in the watch list and then when the
program is halted, the debugger will show all the points in history being
used to make up the filtered reading.

v
[LL]
h ® A C array declared history[10] means the valid subscripts are

FURTHER STUDY .

A Modify the program to keep all LEDs off until 10 samples are obtained.

B Modify the program to handle the LEDs differently on even and odd cycles
as follows:
Even: Show the actual last reading on the LED (not filtered).
Odd: If the last reading is the same as the filtered reading, show
this on the LEDs. Otherwise, turn all LEDs off.
The LED flashes after a change, and when the reading is stable, the LED
will be solid

ACE Kit Exercise Book



TAND-ALONE
ROGRAMS AND EEPROM

U Execution of the EX5.c program always begins counting at 0. This can be modified by

O Jumpers:

creating EX9.c that continues counting where it left off when restarted. This is done by
saving the count value in the PIC16F877A internal data EEPROM. This memory retains

the data even when the power is removed.

Create the EX9.c as follows:

p

\}

#include <prototype.h>
#include <utility.c>

void main () {
int count;

count = read eeprom(0) ;
while (TRUE) {

show binary on leds (count);
wait for one press();
count++;

write eeprom(0,count) ;

pinA5(20) to LED1(42)
pinB4(51) to LED2(43)
pinB5(52) to LED3(44)
pinA4(19) to switch1(40)

L Compile and Run the program. Verify when the program is halted, reset, and restarted

CCS, Inc.

that the count continues where left off.

NOTES

® The first argument to read/write_eeprom is the address in the
EEPROM to write the byte to. The PIC16F877A part ranges from
0 to 255, allowing 256 bytes to be saved. The second argument in
write_eeprom is the value to write.

® There is a limit to how many times a given location in the data
EEPROM can be written to. For example, the PIC16F877 chip allows
100,000 times and the A version of this chip may allow 10 times that
amount. For this reason, a program should be designed not to write
any more often than is necessary. For example, if the volume setting
for a TV is being saved, one might wait until there are no changes for
5 seconds before saving a new value to EEPROM. Some system
designs can give early warning on power down and the program can
only save to EEPROM at power down.
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Close the debug window.

Copy the prototype.h file to a new file protoalone.h. Remove from this file the line:
#device ICD=TRUE

This makes a program that uses the new include file a stand alone program which does
not need the ICD to run.

Modify EX9.c to use protoalone.h. Compile the program, then click Tools>ICD to load
the program onto the Prototyping board.

Disconnect the power from the Prototyping board, then disconnect the ICD from the
Prototyping board.

Power up only the Prototyping board and verify the program runs correctly.

Press the reset button on the Prototyping board and release. The LEDs should go off
while in reset, then the program will restart.

FURTHER STUDY .

A Modify EX7.c so that the cut-off point is a variable and that variable is kept
in EEPROM location 100. Establish a new cut-off point whenever the
pushbutton is pressed to wherever the knob is set. Be careful to only write
the EEPROM once per press.

B Modify the EX9.c program so that 10 EEPROM locations are used and
each time the button is pressed only one of the 10 locations is written to and
the location changes with each press. This will extend the life of this unit by
10 times, if it were a real product.

Hint: The count value could be the sum of all 10 locations %8.
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lJSING A RS-232 PORT

U RS-232is a popular serial communications standard used on most PCs and many
embedded systems. Two wires are used (in addition to ground), one for outgoing data
and one for incoming data. The PIC16F877A chip has built-in hardware to buffer the
serial data if pins C6 and C7 are used. The compiler will allow any pins to be used and
will take advantage of the built-in hardware if choosing these pins. Add the following line
to the end of the protoalone.h file

#use rs232 (baud=9600, xmit=PIN C6, rcv=PIN C7)

U Create the EX10.c as follows:

#include <protoalone.h> A
#include <utility.c>
#include <stdlib.h>
#include <input.c>
void main () {
long a,b,result;
char opr;
setup timer 0 (RTCC INTERNAL) ;
while (TRUE) {
printf ("M\r\nEnter the first number: “);
a=get long();
do {
printf (“"\r\nEnter the operator (+=*/): “);
opr=getc () ;
} while (!isamong (opxr, ”+=*/"));
printf (“"\r\nEnter the second number: “);
b=get long() ;
switch (opr) {
case ‘t+’ : result= atb; break;
case ‘-’ : result= a-b; break;
case ‘*’ : result= a*b; break;
case ‘/' : result= a/b; break;
}
printf (“"\r\nThe result is %lu “,result);
}
}
_ J

U Compile and load the program into the Prototyping board.
CCS, Inc.



U Connect the Prototyping board to the PC as shown below.

O Jumpers: PinC6(7) to RS232 TX (12)
PinC7(8) to RS232 RX (11)

O
U Atthe PC, close the debugger window and start the program Tools>Serial Port
Monitor. Set the correct COMM port if necessary.
U Power up the Prototyping board and a prompt at the PC should appear. Enter a number

followed by the enter key, an operator (like +) and another number followed by enter.
Verify the result is shown correctly.

<
‘ ® The basic functions for RS-232 are putc() and getc(). printf calls putc()

m multiple times to output a whole string and format numbers if
requested. get long() is a function in input.c to read a long number
Ll by calling getc() many times. See input.c for other functions such as
h get_int() and get_string().
® The % in the printf indicates another parameter is included in the printf
o call and it should be formatted as requested. %lu indicates to format
z as an unsigned long.

® getc() will cause the program to stop and wait for a character to come
k in before it returns.

FURTHER STUDY .

Modify to add the operators: % | &

B Modify to use float instead of long. You will need to do get_float() instead
of get_long() and use the format specificier %9.4f to get 4 digits after the
decimal place.
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ORE RS-232 AND

mmSING STRUCTURES

U Create the EX11.c as follows:

N

#include <protoalone.h>
finclude <utility.c>

struct animal { char code;
char name[8];
int count; };

#define MAX 3

struct animal animals[MAX] = {{‘A’,”Ant”,0},
{ \BI 0 "Bird", 0},
{c’,”Cat”,0}};

int find (char code, int & index) {
for (index=0; index<MAX; index++)
if (animals[index] .code==code)
return (TRUE) ;
return (FALSE) ;
}

void main () {
int index;
char code;

while (TRUE) {
printf (“"\r\nEnter the code: “);
code=getc () ;
if (find (code, index) ) {
animals[index] .count++;
printf (“"\r\nYou now have %u %s’s\r\n”,
animals[index] .count,
animals[index] .name) ;
} else
printf ("\r\nCode not valid\r\n”);

}

U Compile and load the program into the Prototyping board.
O Jumpers: pinC6(7) to RS232 TX(12)

PinC7(8) to RS232 RX (11)

U Power up the board and use the serial port monitor to test.

CCS, Inc.
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The int & index is our first example with an output parameter to a
function. The & indicates the value is returned to the caller (actually
the callers copy of the variable is used).

At a hardware level, RS-232 sends a series of bits. The baud=option
specifies how many bits are sent per second. The bit stream, as
specified above, is a start bit (always 0), 8 data bits (Isb first) and a
stop bit (always 1). The line then remains at the 1 level. The number
of bits may be changed with a bits= option and a parity bit can be
added before the stop bit with a parity= option. A O is represented as
a positive voltage (+3 to +12V) and a 1 is represented as a negative
voltage (-3 to —12V). Since the PIC16F877A outputs only OV and 5V
a level converter is required to interface to standard RS-232 devices
such as a PC. A popular chip that does this is the MAX232. See the
schematic in the back cover for details. The following diagram shows
a single character A (01000001) as sent at 9600 baud. The top is from
the PIC16F877A, the bottom is from the MAX232, the 8 data bits are
between the dotted lines. Each bit is 104us.
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FURTHER STUDY

A

B

Modify the program to keep the counts in a separate (from the structure)
array. Then add the CONST keyword before animals to put this data in
ROM instead of RAM. Compare the memory usage for both programs.

If there is room, modify to add new entries when the code is not found. Set
MAX to 6 and add a new variable to keep track of the number of entries.
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.VANCED DEBUGGING

RS-232 printf statements can be a good tool to help debug a program. It does, however,
require an extra hardware setup to use. If the ICD is being used as a debug tool, the
compiler can direct putc() and getc() through the debugger interface to the debugger
screen. Add the following line to the end of the prototype.h file:

#use rs232 (DEBUGGER)

Modify EX10.c to create EX12-1.c by changing protoalone.h to prototype.h.

Compile and load the program into the Prototyping board.

Click GO, then click the Monitor tab.

A prompt should appear. Enter some data to confirm that the program is working.

Stop and reset the program.

In PCW click Project>Open all files as an easy way to get all the project files open in IDE.

Click the stdlib.h tab, and set a breakpoint in the atol() function on the line:
result = 10*result + (c - ‘0’);

This function is called from get_long() to convert a string to a number. This line is executed
for each character in the string.

Click the debugger Break Log tab, check the LOG box, set the breakpoint as 1 and
expression as result. Result is the value of the number being converted.

Click GO, then click the Monitor tab and enter 1234 enter.

Click the Log tab and notice that each time the breakpoint was hit the value of the result
variable was logged. In this case the breakpoint did not cause a full stop of the program, it
just logged the value of the requested expression and kept on going.

Stop the program.

Delete the breakpoint by selecting the breakpoint and click on the E icon.
Uncheck the LOG box under the log tab.

Set a breakpoint on the last printf() in the program.

Enter watches for a, b and resuilt.

Click GO and enter two numbers and +.

When the break is reached click on the snapshot icon: m

Check Time and Watches, uncheck everything else.

If a printer is connected to the PC select Printer, otherwise select Unique file.
Click on the Now button.

Notice the requested data (time and watches) are either printed or written to a file as
requested.

Click on the snapshot icon again and this time select Append to file, put in a filename of
EX12.TXT and check After each single step.
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Check Last C line executed in addition to the Time and Watch selected already and
close the snapshot window.

Reset and then Step Over until the final printf() is executed. Enter the data when
requested.

Use File>Open>Any File to find the file EX12.TXT (by default in the Debugger Profiles
directory) after setting the file type to all files.

Notice the log of what happened with each step over command.

Uncheck the After each single step in the snapshot window.

Clear the breakpoints and set a breakpoint on the switch.

Click Reset then Go and enter the requested data using the + operator.
When the break is reached click on the Peripherals tab and select Timer 0.

Shown will be the registers associated with timer 0. Although this program does not use
timer O the timer is always running so there is a value in the TMRO register. Write this
value down.

Clear the breakpoints and set a breakpoint on the final printf().
Click GO.

Check the TMRO register again. If the new value is higher than the previous value then
subtract the previous value from the current value. Otherwise, add 256 to the current
value and then subtract the previous value (because the timer flipped over).

The number we now have is the number of clock ticks it took to execute the switch and
addition. A clock tick by default is 0.2ms. Multiply your number of ticks by 0.2 to find the
time in ms. Note that the timers (and all peripherals) are frozen as soon as the program
stops running.

FURTHER STUDY .

A The debugger Eval tab can be used to evaluate a C expression. This
includes assignments. Set a break before the switch statement and use the
Eval window to change the operator being used. For example, type a + but
change it to a - before the switch.

B Set a break on the switch statement and when reached, change to the
C/ASM view and single step through the switch statement. Look up the
instructions executed in the PIC16F877A data sheet to see how the switch
statement is implemented. This implementation is dependent on the case
items being close to each other. Change *to ~ and then see how the
implementation changes.
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IMERS

U The PIC16F877A has three built-in timers. Each timer has a different set of features. The

Q
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following example will use Timer #1 to measure the time it takes to execute some
C code.

Create the file EX13.c as follows:

(E#include <prototype.h>

void main () {
long time;

setup timer 1(T1 INTERNAL | T1 DIV BY 1);
set timerl (0);

time = get timerl();
printf (“Time in ticks is $lul\r\n”,time);

\>}

Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)

Compile and Run the program. Check the monitor tab to see the result.

This number is the number of timer ticks that it took to set and read the timer. The

T1_INTERNAL indicates the instruction clock is the source for the timer. The instruction

clock is the oscillator divided by 4, or in our case, 0.2ms. This time represents the
overhead of our timer code and may now be used in a more useful example.

Modify the program as follows and replace the ??? with the number of ticks determined

in the above program.

('#include <prototype.h>

void main () {
long time;
long a,b,c;

setup_timer 1(T1 INTERNAL | T1 DIV BY 1);
set timerl (0);

a=b*c;
time = get timerl();
time -= 2°??; // subtract overhead

printf (“"Time is %1lu microseconds.\r\n”,
(time+2) /5) ;

~
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Since “time” represents the number of 0.2 microsecond ticks that it
takes to do “a=b*c”, then time/5 is the number of microseconds it takes
to do that one line of C code. Use (time + 2)/5 to round instead of
truncating.

All the timers on the PIC16F877A count up and when the maximum
value is reached, the timer restarts at 0. The set_ timer1(0) resets the
timer to 0. Timer 1 is 16 bits and the range is 0 to 65535. This means
it will overflow every 13107.2us. This is the largest time the program
will be able to measure.

If using T1_EXTERNAL instead of INTERNAL, then the timer would
increment every time pin CO cycled. This makes it more of a counter.

If using T1_DIV_BY_2 instead of BY_1, then the timer would
increment once for every 2 instruction clocks. This makes the timer
tick 0.4us and the range of the timer is now 26214.4us.

The following is a summary of the timers on the PIC16F877A chip:

#0 | Input is Instruction Clock or external pin

Range is 0-255

Input can be divided by 1,2,4,8,16,32,64,128,256
Can generate interrupt on each overflow

#1 | Input is Instruction Clock or external pin
Range is 0-65535

Input can be divided by 1,2,4,8

Can generate interrupt on each overflow

#2 | Input is Instruction Clock only

Range can be programmed from 0-1 to 0-255
Input can be divided by 1,4,16

Can generate interrupt on 1-16 overflows

FURTHER STUDY

B Make a program to time the addition operator for 8 bit, 16 bit, 32 bit and

floating point. Instead of int, the compiler allows the use of int8, int16 and
int32 to specify the number of bits in an integer variable.

A Time the actual time for a delay _us(200) to see how accurate the compiler is.
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U Aninterrupt is a specific event that causes the normal program execution to be
suspended wherever it is and an interrupt function is executed. Normal program
execution continues when the interrupt function returns. The PIC16F877A has a
number of interrupt sources such as a timer overflow, an incoming RS-232 character
or a change on a pin.

O In this exercise, the timer 1 overflow interrupt will be used to extend the timer 1 timer
from 16 bits to 32 bits by counting the number of times the timer overflows. Create the
file EX14.c as follows:

(" #include <prototype.h>
intl6 overflow count;

#int timerl
void timerl isr() {
overflow count++;

}

void main () {
int32 time;

setup timer 1(T1 INTERNAL | T1 DIV BY 1);
enable interrupts(int timerl);
while (TRUE) {

enable_interrupts(global);

while (input (PUSH BUTTON) ) ;// Wait for press
set timerl (0);
overflow count=0;

while (!input (PUSH BUTTON)) ;//Wait for release
disable interrupts(global);

time = get timerl();
time = time + ((int32)overflow count<<16) ;
time -= 15; // subtract overhead

printf (“Time is %1lu.%061lu seconds.\r\n”,
time/5000000, (time/5)%1000000) ;

\_!

O Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)
PinA4(19) to switch1(40)

U Compile and Run the program. Press the button, release, and note the time it was held
down is shown to six decimal places in the Monitor pane.
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® The interrupt function is designated by preceding it with #INT_TIMER1.
A number of interrupt functions can be specified by preceding each
with the proper directive like #INT_EXT for the external interrupt pin
(BO) or #INT_RDA for an incoming RS-232 character.

® An interrupt must be specifically enabled (via enable interrupts
(specific interrupt)) and interrupts must be globally enabled (via
enable_interrupts(GLOBAL)). The GLOBAL enable/disable controls
whether any interrupts are serviced.

® Notice interrupts are disabled before the timer is read and combined
with the overflow count. This is done to prevent the following situation:
The timer value is read and it is 65535
The overflow interrupt happens and the counter is incremented to 1
The program continues and reads the counter as 1
The time is assumed to be 65536+65535 when in fact the
correct time is 65535

® Ifinterrupts are disabled and an interrupt event happens, then the
interrupt function will be called when interrupts are enabled. If multiple
interrupt events of the same type happen while interrupts are disabled,
then the interrupt function is called only once when interrupts are
enabled.

® The %06Iu format specifier is the same as %6lu except leading
zeros are printed.

FURTHER STUDY .

A Make a version of this program that prints in the format
MM:SS.FFFFFF
Where MM is minutes, SS is seconds and FFFFFF is fractions of a second.

B Add a second interrupt using timer 0 to interrupt every 13.1ms. In the
interrupt routine, count interrupts and when 76 interrupts have happened,
do a putc(’.’);. This should display a period every second while interrupts
are enabled.
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lSING THE EXPERIMENTER'S SET

U The breadboard may be used to prototype
circuits with components not on the
Prototyping board. The black terminal
block is used to connect jumpers from the
Prototyping board to the breadboard. The
breadboard has two columns on either
side where all the holes in the column
are connected. These are usually used
for +5V and Ground. The inside of the
breadboard is split down the center and
the holes on either side are connected
within the row. The gray shading on the
right diagram shows how the holes are
electrically connected.
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L This exercise will use an external serial EEPROM chip. Create the file EX15.¢, a variation
of EX9.C as follows:

~

#include <protoalone.h>
#include <utility.c>
#include <9356.c>

void main () {
int count;

init ext eeprom();
count = read_ext_eeprom(O);
while (TRUE) {
printf ("\r\nCount=%u", count) ;
wait for one press();
count++;
write ext eeprom(0,count);

\ ! y,

O Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)
PinA4(19) to switch1(40)
PinA5(20) to LED1(42)
PinB4(51) to LED2(43)
PinB5(52) to LED3(44)
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O Wire up the circuit as shown in the following diagram. The diagram on the left shows
how to route the wires. The schematic view below is how the remaining exercises in this
booklet will show the wiring.
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U Compile and Run the program. Verify when the program is halted, reset, and restarted
that the count continues where left off. The output will be shown on serial terminal.

FURTHER STUDY .

A To show your understanding of the breadboard, rewire this same circuit to
use 3 less jumper wires.

B The functions to communicate with the 9356 chip are in 9356.c. Since the
data in and data out pins are not used at the same time they can be the
same pin. Modify the circuit and the 9356.c code so both data in and data
out use the same pin on the PIC16F877A.

ACE Kit Exercise Book



ILOCKING DATA IN AND OUT

U Using the circuit from Exercise 15 enter, compile and test the following program to more

CCS, Inc.

easily test the serial EEPROM:

KE#include <protoalone.h>
#include <stdlib.h>
#include <input.c>
#include <9356.c>

void main () {
int cmd, address;

init ext eeprom();

while (TRUE) {
printf ("\n\n\rEnter address: “);
address = get int();

do {
printf (“"\n\rRead or Write (R, W): “);
cmd = toupper (getc());

} while((cmd != ‘R’) && (cmd != ‘W'));

if (cmd == ‘R’)
printf (“M\n\rvValue is %u”,
read ext eeprom(address));
else if(cmd == ‘W) {
printf ("\n\rEnter data: “);
write ext eeprom(address, get int());

}

\J

-

Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)

The 9356 device being used has four 1/0
connections as shown in this timing diagram.

A diagram like this is typically found in cs /

the device data sheet. The transmission
starts with CS going high on this chip.

. CLK | | | | | | | |
Then the chip expects the DI to change

while the CLK line is low; and it is safe to
be read while the CLK is high. Note that

the clock pulse before CS goes high is not DI 1 0
required. Open the 93LC56 data sheet using

Tools>Internet>Data sheets for Device HIGH.Z
Drivers. DO
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Table 1-4 in the data sheet outlines the command format. All
commands start with a 1 and followed by a 2 or 3 bit command.
Depending on the command there may then be 8 address bits and
8 data bits. Commands in total are either 12 or 20 bits.

The following code makes the CS high, then clocks 20 bits of data out
in accordance with the previous timing diagram. The data is kept in a
three byte array called cmd.
output high (Cs) ;
for (i=1;1i<=20;++1) {
output bit (DI, shift left(cmd,3,0) ;
output high (CLK) ;
output low (CLK) ;
}

The shift_left function shifts all the bits in cmd one position to the left.
The 3 tells the function how many bytes are in cmd and the 0 is the bit
value to shift into the lowest position. The bit shifted out of the highest
position is returned from the function, and in this case then passed to
output_bit. Output_bit() is like output_high/low except that the high/low
is determined at run time by the second parameter.

Open the 9356.c file in the drivers directory. Reviewing the code in
write_ext_eeprom() you will see the code to issue a write command.
When the shift is left, the first byte transmitted is cmd[2]. Since there
are 24 bits in cmd and we only need 20, there is an initial shift of 4 bits
to line up before transmission.

Figure 1-1 in the data sheet shows the required times between events.
For example, the time from CS going high to CLK going high is labeled
as Tcss. Table 1-2 shows Tcss needs to be at least 50ns. Not a
problem in the code.

FURTHER STUDY

A Add a new command to the EX16 program to erase the entire EEPROM. Add

B

a function erase_ext_eeprom() that uses the chip’s ERAL command.

The write_ext_eeprom function in 9365.c has a 11ms delay at the end to wait
for the write to complete. Make a new version of this function that, instead of

a fixed delay, uses the busy check feature described in the data sheet.
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SING AN I*C
EMPERATURE SENSOR

U The previous exercise used 3-4 wires to communicate serially to a chip. That method
is generally referred to as SPI (Serial Port Interface). A popular 2 wire communications
bus that allows multiple devices to use the same two wires was developed by Phillips
Semiconductor and is called I2C. This exercise uses a temperature sensor that
communicates via I?C. Enter the following simple program to use the temperature
sensor.

(>#include <prototype.h> A
#include <dsl1631.c>

void main () {
float value;

init temp();

while (TRUE) {
value = read full temp();
value /= 100.0;
printf (*$3.2f\n\r”, value);
delay ms (1000) ;

\ Y,

 Because multiple devices can use the same two wires, no device ever drives the wires
high. Pull-up resistors on the wires allow them to float high and devices may ground the
wire to make them low. The two wires are designated SDA and SCL. Using the DS1631
chip, wire up the following circuit:

Lgm 1
SDA Voo

[

1K - Y
9 o
sc. L 6
wn A1
3| Tout ()
5
A2
r4 GND

O Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)
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U Compile and Run the program. The monitor window should display the temperature
every second. Hold your finger on the chip to raise the temperature reading.

® Since multiple devices are using the same two wires, each device on
the bus has a 7 bit address. For the DS1631, four of the address bits
are fixed and the other three may be set via the A0, A1, and A2 pins.
In our case we set them all to 0. This means up to eight of these chips
could be on the same two wire bus.

| e Data is transferred over the bus by first sending a unique pattern on
the pins called a start condition. This is followed by the 7 bit address,
m and a bit to designate if data is to transfer to or from the master. The
L master in our case is the PIC16F877A. This byte is followed by any
h number of data types and a stop condition. Some devices allow the
data direction bit without a stop condition. The DS1631 requires a read
o command to be sent to it and then the data direction changes and two
bytes are read from it. The following is an extract of the code from
Z DS1631.C

i2c_start() ;

(
i2c _write (0x90) ; // Address and direction
i2c write (Oxaa) ; // DS1631 command to read
(
(

i2c_start() ;

i2c_write (0x91) ; // Address and direction
datah=i2c_ read();

datal i2c_read(0) ;

i2c_stop();

FURTHER STUDY .

A Make a version of this program that lights the first LED if the temperature is at
or below 75, the second LED if it is 76-79 and the third LED when it is 80 and
up. Be sure to add jumper wires to the LEDs as was done in Exercise 4.

B Each byte on the bus is acknowledged. I12C_WRITE returns a 0 if the byte
was accepted. Make a new version of read_temp() that checks the result of
the first 1I2C_write() and displays an error if the byte was not accepted. Then
change the address from 1001000x to 1001010x and note that the new error
is displayed. Now change the hardware circuit to use the new address.

ACE Kit Exercise Book



IXTERNAL EEPROM USING I*C

U Create the file EX18.C as follows:

p
#include "protoalone.h"
#include <input.c>
#define EEPROM SDA PIN C4
#define EEPROM SCL PIN C3
#include <2416.c>

void main() {

BYTE value, cmd;
EEPROM _ ADDRESS address;

init ext eeprom();

do {
do {
printf(M"\r\nRead or Write: “);
cmd=getc();
cmd=toupper(cmd) ;
putc (cmd) ;
} while ( (cmd!='R’) && (cmd!='W’') );

printf(™\n\rLocation: “);

#if sizeof(EEPROM _ADDRESS)==1

address = gethex();
#else
#if EEPROM _ SIZE>Oxfff
address = gethex();
#else
address = gethexl();
#endif
address = (address<<8)+gethex();
#endif

if(cmd=='R’)
printf(™\r\nvalue: $X\r\n”,READ EXT EEPROM( address ) );

if(cmd=="W") {
printf(“"\r\nNew value: “);
value = gethex();
printf(M\n\r”);
WRITE EXT EEPROM( address, value );
}
} while (TRUE);
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U Wire the circuit as shown in the diagram below.

Serial EEPROM

EX_EXTEE.C

2416.C
+5 28
GND 27

a0 v, fe

A \oTest 7

Hp &scfe
+5 29,%—%,( v,  SDALs
o s ]
cs 4f—L

U Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)

U Compile and Run the program. Verify that the program reads and writes to the external
serial EEPROM.
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.RNAL SERIAL RAM

U Create the file EX19.C as follows:

(

#include <16F877A.h>

#fuses HS,NOWDT,NOPROTECT,NOLVP

#use delay(clock=20000000)

#use rs232(baud=9600, xmit=PIN _C6, rcv=PIN C7)

#include <input.c>
#include <pcf8570.c>

void main() {

BYTE value,cmd;
BYTE address;

do {
do {
printf(M"\r\nRead or Write: “);
cmd=getc();
cmd=toupper (cmd) ;
putc (cmd) ;
} while ( (cmd!='R’) && (cmd!='W") );

printf(“\n\rLocation: “);
address = gethex();

if(cmd=='R")
printf(™\r\nvalue: $X\r\n”,READ EXT SRAM( address )

if(cmd=="W") {
printf(“"\r\nNew value: “);
value = gethex();
printf(™M\n\r”);
WRITE _EXT _SRAM( address, value );
}
} while (TRUE);

)
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U Wire the circuit as shown in the diagram below.

Serial Ram
EX_SRAM.C
PCF8570.C
+5 28
GND 27
A0 oV, |8
B
2] 0 T
A t'-) estlz
21p0 @ SCLJs
+5 29k« ivss SDAls
B1 48 -|
B0 47|—L

U Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)

U Compile and Run the program. Verify that the program reads and writes to the external

serial SRAM.
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ING A 7-SEGMENT

m.’DISPLAY

U 7-Segment LED units are used as an easy way to display numbers. Each of

the 7-segments is an individual LED that can be turned on just as the LEDs on the
Prototyping board. In order to save on I/O pins, it is common to multiplex the LED
segments. In this case, there are two digits. Each segment is connected to the
corresponding segment on the other digit. Only one digit is energized with the correct
segments set. After a short period of time, that digit goes off and the other digit is lit
with its segments on. By alternating very quickly, it will appear that both digits are on
all the time and nine 1/O pins are used instead of 16. Connect up the following circuit to
accomplish this goal:

CCS, Inc.

' NOTES _

Each segment is identified with a designator like a1. Segment a is the top
LED and 1 is the first digit. To light this digit, power up pins 16 and 14. To
light the same segment on digit 2 (a2) then power up pin 16 and 13.

This example does not use the decimal points (DP1 and DP2).

Unlike the onboard LEDs, there is no built-in current limiting resistor on
these units. Many applications will require a series resistor on each of
the segments. In this case, we use a high current LED and know that
the PIC16F877A drive capability will ensure the LED segments are not
damaged.




U The following program will count from 1 to 99. Enter and run the program:

r#include <protoalone.h> R
byte CONST LED MAP[10] =
{0x3f,0x06, 0x5b, 0x4f, 0x66, 0x6d, 0x7d, 0x07,0x7f, 0x67};
void display number ( int n ) {
output b (LED MAP[n/10]);
output low (PIN CO);
delay ms(2);
output high (PIN CO) ;
output b (LED MAP[n%10]);
output low (PIN C1);
delay ms(2);
output high (PIN C1);
}
void main () {
int count=1,i;
while (TRUE) ({
for (1i=0;1<=200;i++)
display number (count) ;
count = (count==99) ? 1 : count+l;
}
!
3| I
m ® Unlike the previous programs, this program writes to all I/O pins on one
wl port at the same time using output_b().
® The LED_MAP array specifies for each number which segments need
h to be on. The first entry (zero) needs segments a, b, ¢, d, e, fon. This
o is BO-B5 or in hex 0x3F.
z ® The ?: notation was used to make it easy to change the increment
value and range with just this one line.
J

FURTHER STUDY .

A Make a version of this program that counts from 00-FF in hex. The hex
digits A, b, C, d, E, F can be displayed using seven segments.

B Use the DS1631 and this display to make a digital thermometer.
ACE Kit Exercise Book



.\L-TIME INTERFACING

U Connect up the circuit to the right NJUG355
using the NJUB355 real-time clock Lo -
chip. This chip can keep accurate A Data
date and time using the small crystal osc ax
attached to the part. The interface to «
the PIC16F877A is an SPI interface.

Internally the date/time is kept in the
chip in BCD.

o

O Jumpers: PinC6(7) to RS232 TX(12)
PinC7(8) to RS232 RX (11)

U Enter and run the following program to demonstrate the real-time clock:

~
#include <protoalone.h>
#include <nju6355.c>
#include <stdlib.h>
#include <input.c>

void set time() {
int hour,min;

printf (M\r\nHour: “); hour=get int();
printf (“"\r\nMin: “); min=get int();
rtc_set datetime(0,0,0,0,hour,min) ;

}

void main () {
int hour,min, sec,last_sec;

rtc_init();
while (TRUE) {
rtc_get time( hour, min, sec );
if (sec!=last sec) {
printf ("\r\n%02u:%02u:%02u”, hour, min, sec);
last_sec=sec;

}
if (kbhit () && (getc()=='S"))
set_time();
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® The kbhit() function returns true if a character comes in the RS-232
port. The && operator evaluates left to right. This means if the kbhit()
returns false, then the getc() is never called. If it were called, the
program would hang here (because there was no character). This
effect is referred to as a short circuit. Not all languages guarantee this,
however, ANSI C does.

FURTHER STUDY .

A Make a version of this program that starts by asking for an alarm hour and
minute. When the alarm time is reached light the third LED. Be sure to
Jjumper the LED to an output port as was done in Exercise 4.

B Update the program to do both date and time. See the NJU6355.c file for
help on the parameters to rtc_set datetime().

NOTES
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.CD AND KEYPAD INTEGRATION

U A convenient way to input and display data is to use a keypad and LCD. The following
example shows how to input characters from the keypad and print them to the LCD. The
‘* * character is special in that it will clear the screen and return the cursor to the top left
corner.

U Create the EX22.C as follows:

"z )\
#include <16F877A.h>
#fuses HS,NOWDT,NOPROTECT,NOLVP
#use delay(clock=20000000)

#include <lcd.c>
#include <kbd.c>

void main() {
char k;
lcd dinit();

kbd _init();
led putc(“\fReady...\n”);

while (TRUE) {
k=kbd getc();
if(k!=0)
if(k=="*")
lcd putc(*\f’);
else
lcd putc(k);
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U Attach the LCD to the LCD Port D female header on prototyping board, and attach the
keypad to the Keypad male header as seen below:
D1 D2 D3 D4 D5 D6 D7N/C

L
2

H-Data
RS “Control

B1

*
14 13
i | ™
2 1
Ground | GND) Display Addresses:
+5 +5
Contrast Pot 10 8A | 8B | 8C | 8D

H-Read
RIW_ CWiite

CA| cB| CcC|cCD

Enable

Data 0

Data 1

olw|~|o|o]ls]e]|d ]|~

Data 2

Data 3

Data 4

Data 5

Data 6

Data 7

U Compile and Run the program. The program will prompt that it is ready for input by
displaying “Ready...” on the LCD. Verify that the program is functioning properly by
inputting numbers on the keypad and confirming that the input is echoed onto the LCD.

[~ Backlight
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.RFACING TOUCH DEVICES

U Create the file EX23.C as follows:

~
#include <16F877A.h>

#fuses HS,NOWDT,NOPROTECT,NOLVP
#use delay(clock=20000000)
#use rs232(baud=9600, xmit=PIN C6, rcv=PIN C7)

#include <touch.c>

void main() {
BYTE buffer[8];
BYTE 1i;

printf(“\r\nWaiting for a touch device...\r\n”);
while (TRUE) {
while (!touch present()) ;
delay ms(200);
if(touch present()) {
touch write byte(0x33);
for(i=0;i<8;++1)
buffer[i]=touch read byte();
printf(“Family: %$2X 1ID: “,buffer[0]);
for(i=6;i!'=0;--1)
printf(“%$2X”,buffer[i]);
printf (™M\r\n”);
delay ms(1000);

CCS, Inc.




U The DS1982 is a one wire EEPROM. The base of the deice should be grounded.
Touching the top of the DS1982 with the touch probe causes data to be transmitted
serially. Wire the circuit as shown in the diagram below.

Touch Devices

EX TOUCH.C
Touch.C
+5 28
§4.7K
Touch
BO 47 Probe
GND_27 DS1982

U Jumpers: pinC6(7) to RS232 TX (12)
pinC7(8) to RS232 RX (11).

U Compile and Run the program. Test that it displays the family code and ID of any device
that “touch”es pin BO.
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l)IGITAL POTENTIOMETERS

U Create the file EX23.C as follows:

( #include <16F877A.h>

#fuses HS,NOWDT,NOPROTECT, NOLVP

#use delay(clock=20000000)

#use rs232(baud=9600, xmit=PIN C6, rcv=PIN C7)

#include <input.c>
#include <dsl868.c>

void main() {
int value;
char pot num;

setup adc ports (ALL ANALOG);
setup adc (ADC CLOCK INTERNAL);
init pots ();

do {
set adc channel (0);
delay wus (100);
value = read adc ();
printf (M\n\r\n\rInput 1: %$2X %, value);

if (NUM POTS > 1) {
set adc channel (1);
delay us (100);
value = read adc ();
printf (“Input 2: $2X \n\r”, value);

do {
printf (“\n\rChange pot 1 or 227);
pot num = getc ();
} while ((pot num!='1") && (pot num!=’'2"));
putc (pot num);
}
else
pot num = ‘1’;

printf (“\n\rNew pot pot value:”);
value = gethex ();

set pot ((pot num-'1"), value);
} while (TRUE);

\_!}
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U The DS1868 is a digital potentiometer that can be used to take the place of the analog
potentiometers. The DS1868 accepts its input from digital signals instead of a mechanical
shaft. The digital potentiometer is controlled by one byte. This value between 0x00 and
OxFF represents the dividing ratio of the internal resistor network. Thus the output is set
proportionally according to the input value. In this example, Vss is represented by 0x00
and Vdd is represented by OxFF. Wire the circuit as shown in the diagram below.

O Jumpers: pinC6(7) to RS232 TX (12)

Digital Pots
EX DPOT.C
DS1868.C
GND 27
+5 28
+5 28 11 HO v d
A0 15 12 W‘Lg v |,
GND 26 e 7
+5 28 20 H1 8 GND
Lf c. B
4 WA :
A1 16 ,f 8
GND 25 =
BO 47 5
B1 48 RST ]
B2 49— |
B3 50

pinC7(8) to RS232 RX (11)
U Compile and Run the program.

U The program will prompt for the potentiometer settings. Set the potentiometer and show
the results by using an analog to digital converter.
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IXPANDED 1/O INTERFACING

U The 74595 is a serial to parallel shift register which has eight stages. Each stage has a
clock and data input. Data is loaded into the shift register when the clock pin changes
from a low to high. The eight shift registers are connected together such that the data
line is connected to the first register and that registers latch output is connected to the
next stage and so on. After the shift register has all the data in place, one pulse on
RCLK causes the eight outputs to change to the new values immediately.

U The 74165 is a parallel to serial shift register. This part uses eight inputs and with each
clock pulse shifts them out bit for bit to the data pin. When the Shift/Load pin on the
part is high, the data line output is high impedance. When the pin goes low, the data is
latched and shifted out each time the clock goes high.

U The above two components may be used to expand the number of 1/O ports that can be
utilized.

O Type in the following program, named EX25.C.

a )

#include <16F877A.h>
#fuses HS,NOWDT,NOLVP,PUT
#use delay(clock=20000000)
#include <74595.c>
#include <74165.c>

void main ()
{
BYTE data;
while (TRUE)
{
read expanded inputs(&data);
data &= 0x03;
write expanded outputs (&data);
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Q

Q

Wire up the circuit as shown in the following diagram. The diagram on the left shows
the connections for the 74165 to create the expanded inputs. The diagram on the right
shows the connections for the 74595 to create the expanded outputs.

Compile and Run the program. Verify that the expanded inputs and outputs are
functioning correctly by pressing the switches in different patterns and checking the
LEDs for correct output. When button 1 is pushed, LED 1 will toggle red. Button 2 will
toggle LED 2 to red. However, when both buttons are pushed, LED 3 will toggle green.

Expanded Input.C Expanded Outputs
EX_EXPIO.C EX_EXPIO.C
74165.C 74595.C
16 +5 28 161V
+5 28 Vcc W10 cc LEDO@2)
1= sw2@) hmw Do fee” e
IGND 27 CE n 8IGND D1 12
| © GND 27 Lel5e D2 P—
8lGND — New n D3 F—\_ New
2 Expanded 2 D4 E Expanded
Bs 52 dor F Inputs By 49 1dps N ps fp( Outeus
3
o — Y SHcp D6 F—
B4 51 cp g 48 D7 f—
12
B3 50 s (LN g0 47 SHep
l To additional Input lg
chips Pin 9
To additional Output
chips Pin 14
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SING THE SIGNAL
ENERATOR BOARD FOR PULSES

U The purpose of the signal generator board is to produce TTL pulses with various
durations and duty cycles. The two 10 position switches on the board set the duration of
high low level of the pulse. The following table shows the possible values..

Selected number Delay in ms

0
0.1

1
10
25
50
100
250
500
1000

OCoO~NOOOTAWN-0

L Connect the ACE kit and the generator board according following instructions. The signal
generator board has six connectors in the left upper side and all pins are described on
the board.

» Connect +5V and GND between the ACE kit and generator board.

» Connect PULSE output on the generator board with PORT B pin 0 on the ACE kit.

» Connect serial monitor between the serial connector A on the board and the PC
serial port.

+ Attach the power source cable and ICD programmer to the ace kit.

U Create the file ex26.c as follows:
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#include <protoalone.h>

unsigned long count high = 0;
unsigned long count low = 0;
unsigned long count all 0;
unsigned long count states =

int state = 0;
int last state = 0;

#int timer2
void timer2 disr()
{

state = input(PIN BO);

count all++;

if (state) count high++;
else count low++;

if (last state != state)

last state = state;

void main() {

float freq, duty;

0;

// prescale 1:1, postacaler 1:1,
setup timer 2(T2 DIV BY 1,200,1);
enable interrupts(int timer2);

// counts H

// counts L

// counts number of executed ISR
// number of signal transition

// actual signal level

//last signal level

count states++;

reset on =200

// enable TIMER2 IRQ
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SING THE SIGNAL GENERATOR
OARD FOR PULSES (CONT.)

: )

(cont.)
while (TRUE)
{
enable interrupts(global);

if (count all >= 50000) // 2sec measurement

{
disable interrupts(global);

freqg
duty

count states/4.0;
(float) count high/count low;

printf(M\r\nTRANS: $Lu”,count states);
printf (Y DUTY: %.3g”,duty);
printf (Y FREQ: %.3g Hz”,freq);

count high = 0;

count low = 0;
count all = 0;
count states = 0;

enable interrupts(global);

The purpose of this program is to measure frequency and duty cycle of the pulses. The
output is send using the serial port. The SIOW serial monitor can be used to monitor the
output.

Compile the program and flash it into the chip using ICD.

Experiment various combinations of the 10 position switches to produce pulses with
different duty-cycles and frequencies. Open the SIOW serial monitor and observe the
results.




MIGRATING TO YOUR
HARDWARE

The following diagram is a somewhat minimal circuit for a PIC16F877A

U Notice this chip has two +5V and ground connections. Some chips have only one of
each. A 0.1uf capacitor mounted near the chip is a good idea and one on either side of
the chip is even better. This will reduce noise both to and from the chip.

U The clock circuit here uses a crystal. With many high speed crystals the resistor on
clock out prevents the crystal from being driven. The capacitor values used are generally
specified in the crystal specification sheets. The PIC16F877A data sheet will show a
number of other options for the clock.

ek

"

"l

1

3

iy -H:-l—t
A MCISFATTA - ]
=

[ e
]
..‘.
BE
ik
o

T.{{.
..{_}q
}

Troubleshooting

U The MCLR pin must be in a high state for the chip to run. Note the Prototyping board
schematic uses a pushbutton to ground this pin and to reset the chip.

U Most problems involve the clock. Make sure the configuration fuses are set to the proper
oscillator setting. In the above case, for a 20MHz crystal HS (High Speed) is the proper
setting. In the above circuit, the size of the resistor may need adjustment depending
upon the crystal.

O If the program does not seem to be running, verify 5 Volts on the MCLR pin and the two
power pins.

U Isolate hardware problems from firmware problems by running a program with the
following at the start of main () and check B0 with a logic probe or scope:
while (TRUE) {
output low (PIN BO);
delay ms (1000);
output high (PIN BO);
delay ms (1000);
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-A1,'|NG TO YOUR OWN
ARE (CONT.)

The In-Circuit Progamming/Debugging Interface

U To program and/or debug in circuit, two /O pins (B6, B7) are reserved. If debugging is
not to be done, then these pins may also be used in the target circuit. However, care
must be taken to ensure the target circuit has high impedance during programming.

U The MCLR pin is also used by the programmer and for debugging. Note that during
programming, the voltage on this is 13 volts. The 47K resistor to 5V is sufficient isolation
for the 13V. However, if anything else is connected to the MCLR pin, be sure the 13V will
not damage or interfere.

U The ICD unit requires V,, from the target. It is easiest to power up the target normally
and then, connect the target board V , to the ICD for power. The ICD-S40 is powered by
this pin (5V) and the ICD-U40 uses it to pull up the signals (3V-5V).

U The B3 pin is optional and is not used for programming. However, the Monitor feature
of the debugger does use B3. It is possible to program and debug (without monitor) and
allocate B3 to the target hardware. In this case do not connect B3 to the ICD connector

Vdd

A

vdd

MCLR
A

47K

PGD (usually B7)
PGC (usually Bé)
B3 (optional)

VSS

PIC

Target ICD connector
Looking into the connector

U Note that the ICD to target cable reverses the pins so the MCLR signal is ICD pin 6 and
that connects to the target pin 1.
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This booklet is not intended to be a tutorial for the C programming language. It does attempt
to cover the basic use and operation of the development tools. There are some helpful tips
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For the reader not using this as a part of a class and without prior C experience the following
references should help.
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Other Development Tools

EMULATORS

The ICD used in this booklet uses two 1/O pins on the chip to communicate with a small
debug program in the chip. This is a basic debug tool that takes up some of the chip’s
resources (I/0O pins and memory). An emulator replaces the chip with a special connector that
connects to a unit that emulates the chip. The debugging works in a similar manner except
that the chip has all of its normal resources, the debugger runs faster and there are more
debug features. For example an emulator typically will allow any number of breakpoints.
Some of the emulators can break on an external event like some signal on the target board
changing. Some emulators can break on an external event like some that were executed
before a breakpoint was reached. Emulators cost between $500 and $3000 depending on the
chips they cover and the features.

DEVICE PROGRAMMERS

The ICD can be used to program FLASH chips as was done in these exercises. A stand
alone device programmer may be used to program all the chips. These programmers will
use the .HEX file output from the compiler to do the programming. Many standard EEPROM
programmers do know how to program the Microchip parts. There are a large number of
Microchip only device programmers in the $100-$200 price range. Note that some chips
can be programmed once (OTP) and some parts need to be erased under a UV light before
they can be re-programmed (Windowed). CCS offers the Mach X which is a stand-alone
programmer and can be used as an in-circuit debugger.

PROTOTYPING BOARDS

There are a large number of Prototyping boards available from a number of sources.

Some have an ICD interface and others simply have a socket for a chip that is externally
programmed. Some boards have some advanced functionality on the board to help design
complex software. For example, CCS has a Prototyping board with a full 56K modem on
board and a TCP/IP stack chip ready to run internet applications such as an e-mail sending
program or a mini web server. Another Prototyping board from CCS has a USB interface chip,
making it easy to start developing USB application programs.

SIMULATORS

A simulator is a program that runs on the PC and pretends to be a microcontroller chip.

A simulator offers all the normal debug capability such as single stepping and looking at
variables, however there is no interaction with real hardware. This works well if you want to
test a math function but not so good if you want to test an interface to another chip. With the
availability of low cost tools, such as the ICD in this kit, there is less interest in simulators.
Microchip offers a free simulator that can be downloaded from their web site. Some other
vendors offer simulators as a part of their development packages.



CCS Programmer Control Software

The CCSLOAD software will work for all the CCS device programmers and replaces the
older ICD.EXE and MACHX.EXE software. The CCSLOAD software is stand-alone and
does not require any other software on the PC. CCSLOAD supports ICD-Sxx, ICD-Uxx,
Mach X, Load-n-Go, and PRIMES.

Powerful Command Line Options in Windows and Linux
- Specify operational settings at the execution level
- Set-up software to perform, tasks like save, set target Vdd
- Preset with operational or control settings for user

Easy to use Production Interface
- Simply point, click and program
- Additions to HEX file organization include associating comments or a graphic image
to a file to better ensure proper file selection for programming
- Hands-Free mode auto programs each time a new target is connected to the programmer
- PC audio cues indicate success and fail

Extensive Diagnostics
- Each target pin connection can be individually tested
- Programming and debugging is tested with known good programs
- Various PC driver tests to identify specific driver installation problems

Enhanced Security Options
- Erase chips that failed programming
- Verify protected code cannot be read after programming
- File wide CRC checking

Automatic Serial Numbering Options
- Program memory or Data EEPROM
- Incremented, from a file list or by user prompt
- Binary, ASCII string or UNICODE string

CCS IDE owners can use the CCSLOAD program with:
- MPLAB®ICD 2/ICD 3
- MPLAB®REAL ICE™
- All CCS programmers and debuggers

How to Get Started:

Step 1: Connect Programmer to PC and target board. Software will auto-detect the
programmer and device.

Step 2: Select Hex File for target board.

Step 3. Select Test Target. Status bar will show current progress of the operation.

Step 4: Click “Write to Chip” to program the device.

Use the Diagnostics tab for troubleshooting or the ccsload.chm help file for additional assistance.



SCHEMATICS

Software Prototyping Board
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.IEMATICS

LCD & Keypad
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Serial EEPROM

Experimenter’s Kit

Serial EEPROM

EX-ELT?EC EX_EXTEE.C
5 28 . 9356.C
GND 27 Gnd 27
45 28
B4 51 qcs Ve |
Q Test
B2 49 Hewk et
© ORG |s
Bl 48 2101
+5 29‘%—K v, SDA |s B0 47 £ Y V., |s
B1 48
|BO 47
Real Time Clock Temperature Sensor
EX_RTC.C EX_TEMP.C
NJU6355.C Ds1621.C
45 +5 28 T3 é
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NOTE: Crystal Leads are too small to
insert directly into Prototyping Board.
Solder leads to chip.
Digital Pots Serial Ram
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For example, both switches set to 7
will yield a 2hz 50% duty square wave.
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Touch.C
+5 28
47K
Touch
BO 47 Probe
Expanded Input.C
EX_EXPIO.C
74165.C
s 28 vee
DO —
150 =— 12
IGND 27 CE D1
% D2 p2—
8IGND — D3 f&—0v \ New
ﬁ pafe Expanded
B5 49 o7 ¥ psf— | Ineus
A D6 p—
B4 48 cP D7
1
B3 47 PL 10
lTo additional Input
chips Pin 9
Expanded Outputs
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- Hold until one
shot pressed
- 100us 6- 100ms
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Parts:

1 USB Connector
 PIC18F4550 IC Chip*
 .47uf 0805 Capacitor

SCHEMATICS

USB Add-On

Parts Installation:
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