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Inventory
 Use of this kit requires a PC with Windows 95, 98, ME, NT, 2000 or XP.  The PC must 

have a spare 9-Pin Serial or USB port, a CD-ROM drive and 75 MB of disk space.

 The diagram on the following page shows each component in the PIC18F67J10 kit.Ensure 
every item is present.

Software
 Insert the CD into the computer and wait for the installation program to start. If your computer 

is not set up to auto-run CDs, then select My Computer and double-click on the CD drive.

 Click on Install and use the default settings for all subsequent prompts by clicking NEXT, 
OK, CONTINUE…as required.

 Identify a directory to be used for the programs in this booklet. The install program will 
have created an empty directory c:\program fi les\picc\projects that may be used for 
this purpose.

 Select the compiler icon on the desktop. In the PCW IDE, click Help>About and verify 
a version number is shown for the IDE and PCH to ensure the software was installed 
properly. Exit the software.

Hardware
 Connect the PC to the ICD(6) using the USB cable. Connect the prototyping board (10) to 

the ICD using the modular cable.  Plug in the DC adaptor (9) to the power socket and plug 
it into the prototyping board (10). The fi rst time the ICD-U is connected to the PC, Windows 
will detect new hardware. Install the USB driver from the CD or website using the new 
hardware wizard. The driver needs to be installed properly before the device can be used.

 The LED should be red(1) on the ICD-U to indicate the unit is connected properly.

 Run the Programmer Control Software by clicking on the CCSLOAD icon on the desktop. 
Use CCSLOAD Help File for assistance. 

 The software will auto-detect the programmer and target board and the LED should be 
illuminated green. If any errors are detected, go to Diagnostic tab. If all tests pass, the 
hardware is installed properly.

 Disconnect the hardware until you are ready for Chapter 3. Always disconnect the power 
to the Prototyping board before connecting/disconnecting the ICD or changing the 
jumper wires to the Prototyping board.

1 UNPACKING AND
INSTALLATION

(1) ICD-U40 units will be dimly illuminated green and may blink while connecting.
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1 Storage box
2 Exercise booklet
3 CD-ROM of C compiler (optional)
4 Serial PC to Prototyping board cable
5 Modular ICD to Prototyping board cable
6 ICD unit for programming and debugging
7 Parts box includes: 

    93LC56 serial EEPROM chip
    DS1631 digital thermometer chip
    NJU6355 real-time clock chip with attached 32kHz crystal
    Two digit 7 segment LED module
    Two 1K resistors
    Jumpers to connect the Prototyping board to the breadboard
 8 USB (or Serial) PC to ICD cable
 9 AC Adaptor (9VDC)
10 Prototyping board with a PIC18F67J10 processor chip 

  (See inside front and back cover for details on the board layout and schematic)
11 Breadboard for prototyping circuits
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2 USING THE INTEGRATED 
DEVELOPMENT ENVIRONMENT (IDE)

Editor
 Open the PCW IDE. If any fi les are open, click File>Close All

 Click File>Open>Source File. Select the fi le: c:\program fi les\picc\examples\ex_
stwt.c

 Scroll down to the bottom of this fi le. Notice the editor shows comments, preprocessor 
directives and C keywords in different colors. 

 Move the cursor over the Set_timer0 and click. Press the F1 key. Notice a Help fi le 
description for set_timer0 appears. The cursor may be placed on any keyword or built-in 
function and F1 will fi nd help for the item.

 Review the editor special functions by clicking on Edit. The IDE allows various standard 
cut, paste and copy functions.

 Review the editor option settings by clicking on Options>Editor Properties. The 
IDE allows selection of the tab size, editor colors, fonts, and many more.  Click on 
Options>Toobar to select which icons appear on the toolbars. 

Compiler
 Use the drop-down box under Compile to select the compiler. CCS offers different 

compilers for each family of Microchip parts. All the exercises in this booklet are for the 
PIC18F67J10 chip, a 16-bit opcode part. Make sure PCH 16 bit is selected in the drop-
down box under the Compiler tab.

 The main program compiled is always shown in the bottom of the IDE. If this is not the 
fi le you want to compile, then click on the tab of the fi le you want to compile. Right click 
into editor and select Make fi le project.

 Click Options>Project Options>Include Files… and review the list of directories 
the compiler uses to search for included fi les. The install program should have put two 
directories in this list: devices and drivers.

 Normally the fi le formats need not be changed and global defi nes are not used in these 
exercises. To review these settings, click Options>Project Options>Output File and 
Options>Project Options>Global Defi nes.

 Click the compile icon to compile. Notice the compilation box shows the fi les created 
and the amount of ROM and RAM used by this program. Press any key to remove the 
compilation box.
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Viewer
 Click Compile>Symbol Map. This file shows how the RAM in the microcontroller is used. 

Identifiers that start with @ are compiler generated variables. Notice some locations are used 
by more than one item. This is because those variables are not active at the same time. 

 Click Compile>C/ASM List. This file shows the original C code and the assembly code 
generated for the C. Scroll down to the line: 
  int_count=INTS_PER_SECOND;

 Notice there are two assembly instructions generated. The first loads 4C into the W 
register. INTS_PER_SECOND is #defined in the file to 76. 4C hex is 76 decimal. The 
second instruction moves W into memory. Switch to the Symbol Map to find the memory 
location where int_count is located.

 Click View>Data Sheet, then View. This brings up the Microchip data sheet for the 
microprocessor being used in the current project.

Click here for the file menu.  Files and Projects are created, 
opened, or closed using this menu.

Place cursor here for slide out boxes.  
All of the current project’s source and 
output files can be seen here.

Compile ribbon.

Place cursor over each icon 
and press F1 for help.

Click the help icon for 
the help menu.  The technical 
support wizard and download 
manager are accessed using 
this menu.

Compiles current selected unit, does NOT link/build  
into a HEX file.

Quick view of supported devices.

Compiles all units that have changed since last build,  
links/builds into a HEX file.

Compiles all units regardless if they have changed since 
last build, links/builds into a HEX file.
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 Open the PCW IDE. If any fi les are open, click File>Close All

 Click File>New>Source File and enter the fi lename EX3.C

 Type in the following program and Compile.

3 COMPILING AND 
RUNNING A PROGRAM

N
O

T
E

S

 The fi rst four lines of this program defi ne the basic hardware 
environment.  The chip being used is the PIC18F67J10, running at 
20MHz with the ICD debugger.

 The #defi ne is used to enhance readability by referring to 
GREEN_LED in the program instead of PIN_C0.

 The “while (TRUE)” is a simple way to create a loop that never stops.

 Note that the “output_low” turns the LED on because the other end of 
the LED is +5V. This is done because the chip can tolerate more cur-
rent when a pin is low than when it is high.

 The “delay_ms(1000)” is a one second delay (1000 milliseconds).

#include <18F67J10.h>
#device ICD=TRUE
#fuses  HS,NOWDT
#use delay (clock=20000000)

#defi ne GREEN_LED PIN_CO

void main () {
 while (TRUE) {
  output_low (GREEN_LED);
   delay_ms (1000);
  output_high (GREEN_LED);
  delay_ms (1000);
 }
}
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 Modify the program to light the green LED for 5 seconds, then the yellow for 
1 second and the red for 5 seconds. 

 Add to the program a #define  macro called “delay_seconds” so the delay_
ms(1000) can be replaced with : delay_seconds(1); and delay_ms(5000) 
can be: delay_seconds(5);.

Note:  Name these new programs EX3A.c and EX3B.c and follow the same  
  naming convention throughout this booklet.

A

B

FURTHER STUDY

 Connect the ICD to the Prototyping board using the modular cable, and connect the ICD to 
the PC using the USB cable for ICD-U. Power up the Prototyping board.

 Click Debug>Enable Debugger and wait for the program to load. 

 If you are using the ICD-U40 and the debugger cannot communicate to the ICD unit go to 
the debug configure tab and make sure ICD-USB from the list box is selected. 

 Click the green go icon: 

 Expect the debugger window status block to turn yellow indicating the program is running. 

 The green LED on the Prototyping board should be flashing. One second on and one 
second off. 

 The program can be stopped by clicking on the stop icon:  

ICD-U64



CCS, Inc.

 Type in the following program, named EX4.C, Compile and Run:

 As can be seen from the program, the green LED should come on.  Press the button 
and the yellow LED should light and then the red LED when pressed again.  

 Add the following new type below the // lines:  
typedef enum  {GREEN,YELLOW,RED}  colors; 

4 HANDLING INPUT

As can be seen from the program, the green LED should come on.  Press the button 

#include <18F67J10.h>
#device ICD=TRUE
#fuses  HS,NOWDT
#use delay(clock=20000000)

#defi ne GREEN_LED PIN_CO
#defi ne YELLOW_LED PIN_B4
#defi ne RED_LED PIN_B5
#defi ne PUSH_BUTTON PIN_A4
//
void light_one_led(int led) {
 output_high(GREEN_LED);
 output_high(YELLOW_LED);
 output_high(RED_LED);
 switch(led) {
  case 0 : output_low(GREEN_LED);  break; 
  case 1 : output_low(YELLOW_LED); break; 
  case 2 : output_low(RED_LED);    break; 
 }  
}

void wait_for_one_press() {
 while(input(PUSH_BUTTON)) ;
 while(!input(PUSH_BUTTON)) ;
}  

void main() {
 while(TRUE) {
   light_one_led(0); 
   wait_for_one_press();
   light_one_led(1); 
   wait_for_one_press();
   light_one_led(2); 
   wait_for_one_press();
 }
}



PIC18F67J10 Exercise Book

 Modify the program so that while the button is held down the LEDs alternate 
as fast as possible. When the button is not pressed the LED state freezes. 
This creates a random color program.

A

FURTHER STUDY

N
O

T
E

S

 The Prototyping board has one momentary pushbutton that may be 
used as an input to the program. The input pin is connected to a 4.7K 
pull-up resistor to +3.3V.  The button, when pressed, shorts the input 
pin to ground. The pin is normally high while in this confi guration, but it 
is low while the button is pressed.

 This program shows how to use simple C functions. The function 
wait_for_one_press() will fi rst get stuck in a loop while the input pin 
is high (not pressed). It then waits in another loop while the pin is low. 
The function returns as soon as the pin goes high again. Note that 
the loops, since they do not do anything while waiting, do not look like 
much-they are a simple ; (do nothing).

 When the button is pressed once, it is common for several very quick 
connect disconnect cycles to occur. This can cause the LEDs to 
advance more than once for each press. A simple debounce 
algorithm can fi x the problem. Add the following line between the two 
while loops: delay_ms(100); The following scope picture of a button 
press depicts the problem:

 Change the parameter to light_one_led to colors instead of int. 

 Change the 0,1,2 in the call to GREEN, YELLOW, RED.
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 It is good practice to put all the hardware defi nitions for a given design into a common 
fi le that can be reused by all programs for that board. Open EX4.C and drag the cursor 
over (highlight) the fi rst 9 lines of the fi le. Click Edit>Paste to fi le and give it the name 
prototype.h.

 It is also helpful to collect a library of utility functions to use as needed for future programs. 
Note that just because a function is part of a program does not mean it takes up memory. 
The compiler deletes functions that are not used. Highlight the wait_for_one_press() 
function, light_one_led function and the typedef line (if added from Chapter 4 section) and 
save as a new fi le named utility.c. Open utility.c and add the following new function to the 
fi le:

 Close all fi les and start a new fi le named EX5.C as follows:

5 PROGRAM STRUCTURE

void show_binary_on_leds(int n) {
 output_high(GREEN_LED);
 output_high(YELLOW_LED);
 output_high(RED_LED);
 if( bit_test(n,0) )
  output_low(GREEN_LED); 
 if( bit_test(n,1) )
  output_low(YELLOW_LED); 
 if( bit_test(n,2) )
  output_low(RED_LED);  
}

#include <prototype.h>
#include <utility.c>

void main() {
 int count = 0;

 while(TRUE) {
  show_binary_on_leds(count);
  wait_for_one_press();
  count++;
 }
}
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Where it is defi ned Can be accessed Life of the variable
Inside a function Only in that function While function is alive
Inside a function with 
STATIC Only in that function During the entire run of 

the program

Outside all functions In any function defi ned 
afterwards in the fi le

During the entire run of 
the program

After { inside a function Only between the { and 
corresponding }

Only up to the 
corresponding }

 Modify the program to increment the binary number 1 every second (the 
button is not used).

 Instead of the built-in function BIT_TEST use the standard C operators (such 
as & and ==) to test the bits.

A

B

FURTHER STUDY

N
O

T
E

S

 In C, a function must either appear in the input stream before it is used 
OR it must have a prototype.  A prototype is the part of the function
defi nition before the {.  In a program where main calls function A and func-
tion A calls function B, the order in the fi le must be B, A, MAIN.  As an 
alternative, have Ap, Bp, MAIN, A, B where Ap and Bp are prototypes.  
Frequently, prototypes are put into a header fi le with a .h extension.

 The scope, initialization, and life of C variables depend on where and 
how they are declared.  The following is a non-inclusive summary of the 
common variable scopes.  Note that if a variable has an initialization (like 
int a=1;) the assignment happens each time the variable comes to life.

 Compile and Run the program.  Check that 
with each button press, the LEDs increment 
in a binary number 0-7 as shown here.

0 0 0 0
0 0 1 1
0 1 0 2
0 1 1 3
1 0 0 4
1 0 1 5
1 1 0 6
1 1 1 7
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6 DEBUGGING

 Open EX5.C and start the debugger Debug>Enable Debugger.
 Click the reset icon to ensure the target is ready.

 Click the step-over icon  twice. This is the step over command. Each click causes a 
line of C code to be executed. The highlighted line has not been executed, but the line 
about to be executed. 

 Step over the show _ binary _ on _ leds(count); line and notice that one click 
executed the entire function. This is the way step over works. Click step over  on 
wait _ for _ one _ press();. Press the prototype button and notice the debugger 
now stops since the function terminates. 

 Click the Watch tab, then the add icon  to add a watch. Enter count or choose 
count the variables from list, then click Add Watch. Notice the value shown. Continue 
to step over through the loop a few more times (press the button as required) and notice 
the count watch increments.

 Step over until the call to show _ binary _ on _ leds(count); is highlighted. This 
time, instead of step over, use the standard step icon  several times and notice the 
debugger is now stepping into the function.

 Click the GO icon  to allow the program to run. Press the prototype button a couple 
of times to verify that the program is running normally. Click the stop icon  to halt 
execution. Notice the C source line that the program stopped on. This is the line were the 
program is waiting for a button press. 

 In the editor, click on show _ binary _ on _ leds(count); to move the editor cursor 
to that line. Then click the Breaks tab and click the add icon  to set a breakpoint. The 
debugger will now stop every time that line is reached in the code. Click the GO icon  
and then press the prototype button. The debugger should now stop on the breakpoint. 
Repeat this a couple of times to see how the breakpoint works. Note that the ICD with 
PIC16 chips only allow one breakpoint at a time.

 Click Compile>C/ASM list. Scroll down to the highlighted line. Notice that one assembly 
instruction was already executed for the next line. This is another side effect of the ICD-S 
debugger. Sometimes breakpoints slip by one ASM instruction. 

 Click the step over icon  a few times and note that when the list fi le is the selected 
window, the debugger has executed one assembly instruction per click instead of one 
entire C line.

 Close all fi les and start a new fi le EX6.C as follows: 
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#include <prototype.h>
#include <utility.c>

void main() {
 int a,b,c;

 a=11;
 b=5; 
 c=a+b;
 c=b-a;
 while(TRUE);
}

 Modify the program to include the following C operators to see how they work: 
*   /   %   &   ^ 
Then, with b=2 try these operators: >>  <<
Finally, try the unary complement operator with: c=~a;

 Design a program to test the results of the relational operators:
<     >     = =    !=
by exercising them with b as 10, 11, and 12.
Then, try the logical operators || and && with the four combinations of a=0,1 
and b=0,1.
Finally, try the unary not operator with: c=!a; when a is 0 and 1.

A

B

FURTHER STUDY

 Compile the program and step-over until the c=a+b is executed. Add a watch for c and 
the expected value is 16.

 Step-over the subtraction and notice the value of c. The int data type by default is 
not signed, so c cannot be the expected –6. The modular arithmetic works like a car 
odometer when the car is in reverse only in binary. For example, 00000001 minus 1 is 
00000000, subtract another 1 and you get 11111111.

 Reset and again step up to the c=a+b. Click the Eval tab. This pane allows a one time 
expression evaluation. Type in a+b and click Eval to see the debugger and calculate the 
result. The complete expression may also be put in the watch pane as well. Now enter 
b=10 and click Eval. This expression will actually change the value of B if the “keep side 
effects” check box of the evaluation tab is checked.  Check it and click Eval again. 
Step-over the addition line and click the Watch tab to observe the c value was calculated 
with the new value of b. 
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7 ANALOG TO DIGITAL 
CONVERSION

 The PIC18F67J10 chip has 11 pins that may be used to read an analog voltage.  These 11 
pins can be confi gured to certain combinations of analog input and digital pins, but not all 
combinations are possible.  The following is a simple program (EX7.c) to read one analog pin.

#include <prototype.h>
#include <utility.c>

#defi ne cutoff 128        // 1.65 Volts
#defi ne neutral_zone 25   // 0.32 Volts

void main() {
 int reading;

 setup_adc_ports( AN0 );
 setup_adc( ADC_CLOCK_INTERNAL );
 set_adc_channel( 0 );

 while(TRUE) {
  reading = read_adc();
  if(reading<(cutoff-neutral_zone/2))
   light_one_led(GREEN);
  else if (reading>(cutoff+neutral_zone/2))
   light_one_led(RED);
  else 
   light_one_led(YELLOW);
 }
} 

 Compile and Run the program.  Verify that the Prototyping board knob (A0) is turned so 
the green LED is on when it is low, the red LED when high and the yellow LED for a small 
region in the center.

1.65V

0V 3.3V
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 Modify the program to use a long variable for reading.  Open prototype.h and 
after:
 #device ICD=TRUE
add the following
 ADC=10
This will change the range to 0-1023.  Change the constant in the program to 
refl ect the new range.
When the above example is complete, remove the ADC=10 so it will default 
to ADC=8

 Write a timer program that will light the green LED for x seconds when 
pressing the button.  x should be 0-25,  depending on the setting of the 
analog knob.

A

B

FURTHER STUDY

N
O

T
E

S
 By default, the analog to digital converter is 8 bits.  Thus, a range of 0 

to 3.3 volts analog is represented by the numbers 0-255.  The A/D 
reading can be converted to volts by the formula:
 Volts = reading*(5.0/255)

 The setup_adc_ports function call determines what pins are set to 
be analog inputs.  The setup_adc function call determines how fast 
the conversion is done.  The internal clock option uses an internal RC 
clock.  Although the timing is not exact, it is long enough for an 
accurate conversion.  The time can be based off the instruction clock 
for more precise timing.

 The set_adc_channel function sets the A/D converter to channel 0 
(AN0 or A0).  This switches an internal mux in the part, but does not 
start an A/D conversion.  Even though a conversion has not started, 
there is a small capacitor in the chip that must charge up after the port 
switch and before the voltage is read.  This is fast with a low 
impedance input, but for a higher impedance input, a small delay 
should be put in after the channel is changed.

 The call to read_adc starts a conversion, waits for it to complete and 
returns the result.  The conversion time is around 20µs.
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8 ARRAYS AND 
ANALOG FILTERING

 The following EX8.c program illustrates how to change the EX7.c program such that the 
value used to light the LED is the average voltage over the previous 10 seconds.

#include <prototype.h>
#include <utility.c>

#defi ne cutoff 128   // 1.65 volts
#defi ne neutral_zone 25  // 0.32 Volts

void main()  {
 int history[10],i;
 int history_ptr = 0;
 long reading;
 int count=0;

 setup_adc_ports( AN0 );
 setup_adc( ADC_CLOCK_INTERNAL );
 set_adc_channel ( 0 );

 while (TRUE)  {
  reading=0;
  delay_ms(1000);
  history[history_ptr++] = read_adc();
  if (history_ptr==10)  {
   history_ptr=0;
   count = 10;
  } else
   if (count<10)
    count=history_ptr;
  for (i=0; i<count;i++)
   reading += history[i];
  reading /= count;
  if (reading<(cutoff-neutral_zone/2))
   light_one_led(GREEN);
  else if (reading>(cutoff+neutral_zone/2))
   light_one_led(RED);
  else
   light_one_led(YELLOW);
 }
}
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 Run the new program and confi rm that the movement of the knob takes 10 seconds to 
appear on the LEDs. Furthermore, confi rm that a quick movement of the knob from high 
to low makes no difference in the LEDs.

 Modify the program to keep all LEDs off until 10 samples are obtained.
 Modify the program to handle the LEDs differently on even and odd cycles as 

follows:
 Even: Show the actual last reading on the LED (not fi ltered).
 Odd: If the last reading is the same as the fi ltered reading, show 
  this on the LEDs.  Otherwise, turn all LEDs off.
The LED fl ashes after a change, and when the reading is stable, the LED will 
be solid.

A
B

FURTHER STUDY

N
O

T
E

S

 This program uses several of the C shortcut operators.  For example, the 
 reading += history[i] is the same as 
 reading = reading + history[i]
 and history[history_ptr++] = read_adc(); is the same as
 history[history_ptr] = read_adc();
 history_ptr = history_ptr+1;

A C array declared history[10] means the valid subscripts are 
history[0] through history[9].
The reading variable needs to be a long (16 bits) because the largest 
value 255*10 is larger than 8 bit int.
The history variable can be placed in the watch list and then when the 
program is halted, the debugger will show all the points in history being 
used to make up the fi ltered reading.






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9 STAND-ALONE PROGRAMS AND 
USING A RS-232 PORT

 RS-232 is a popular serial communication standard used on most PCs and many 
embedded systems. Two wires are used (in addition to ground), one for outgoing data 
and one for incoming data. The PIC18F67J10 chip has built-in hardware to buffer the 
serial data if pins C6 and C7 or G1 and G2 are used. The compiler will allow any pins to 
be used and will take advantage of the built-in hardware if you pick those pins.  

 Copy the prototype.h fi le to a new fi le protoalone.h.  Remove from this fi le, the line:
#device ICD=TRUE  
This makes a program that uses the new include fi le a stand alone program which does 
not need the ICD to run
For using the RS-232 port on the pins C6 and C7, add the following line to the 
protoalone.h fi le:  #use rs232(baud =9600, xmit=Pin_C6, rcv=Pin_C7)

 Create the Ex9.c as follows:
#include <protoalone.h>
#include <utility.c>
#include <stdlib.h>
#include <input.c>

void main() {
 long a,b,result;
 char opr;

 setup_timer_0(RTCC_INTERNAL); 
 while(TRUE) {
  printf(“\r\nEnter the fi rst number: “);
  a=get_long();

  do {  
   printf(“\r\nEnter the operator (+-*/): “);
   opr=getc();
  } while(!isamong(opr,”+-*/”));

  printf(“\r\nEnter the second number: “);
  b=get_long();

  switch(opr) {
   case ‘+’ : result= a+b;   break;
   case ‘-’ : result= a-b;   break;
   case ‘*’ : result= a*b;   break;
   case ‘/’ : result= a/b;   break;
  } 

(continued...)
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 Compile the program then click Tools > ICD to load the program onto the proto board.

 Connect the Prototyping board to the PC as shown below.

 At the PC, close the debugger window and start the program Tools>Serial Port 
Monitor.  Set the correct COMM port if necessary.

 Power up the Prototyping board and a prompt at the PC should appear.  Enter a number 
followed by the enter key, an operator (like +) and another number followed by enter.  
Verify the result is shown correctly.  

N
O

T
E

S

 The basic functions for RS-232 are putc() and getc(). printf calls putc() 
multiple times to output a whole string and format numbers if request-
ed.  get_long() is a function in input.c to read a long number by calling 
getc() many times.  See input.c for other functions such as get_int() 
and get_string().

 The % in the printf indicates another parameter is included in the printf 
call and it should be formatted as requested.  %lu indicates to format 
as an unsigned long.

 getc() will cause the program to stop and wait for a character to come 
in before it returns.

 Modify to add the operators: % | & ^
 Modify to use fl oat instead of long.  You will need to do get_fl oat() instead 

of get_long() and use the format specifi cier %9.4f to get 4 digits after the 
decimal place.

A
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FURTHER STUDY

(continued...)
  printf(“\r\nThe result is %lu “,result);
 }
}  
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TWO RS-232 PORTS10
 Create the EX10.c as follows:

#include <protoalone.h>

#use rs232(baud=9600, xmit=PIN_C6, rcv=PIN_C7, stream=PORT1)
#use rs232(baud=9600, xmit=PIN_G1, rcv=PIN_G2, stream=PORT2)

void main() {
 char c; 

 fprintf(PORT1, “\r\n PORT ONE \r\n”); 
 fprintf(PORT2, “\r\n PORT TWO \r\n”); 

 while(TRUE) {
  if(kbhit(PORT1)) {
   c=fgetc(PORT1);
   fputc(c+1,PORT2);
  }  
  if(kbhit(PORT2)) {
   c=fgetc(PORT2);
   fputc(c-1,PORT1);
  }
 }
}

 Compile and load the program into the 
Prototyping board.

 Power up the board and use the serial port 
monitor to test.

 Press and release the RESET button to start the 
program.
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 At a hardware level, RS-232 sends a series of bits. The baud=option 

specifi es how many bits are sent per second. The bit stream, as 
specifi ed above, is a start bit (always 0), 8 data bits (lsb fi rst) and a 
stop bit (always 1). The line then remains at the 1 level. The number 
of bits may be changed with a bits=option and a parity bit can be 
added before the stop bit with a parity=option. A 0 is represented as 
a positive voltage (+3 to +12V) and a 1 is represented as a negative 
voltage (-3 to –12V). Since the PIC18F67J10 outputs only 0V and 3.3V 
a level converter is required to interface to standard RS-232 devices 
such as a PC.  A popular chip that does this is the MAX232. See the 
schematic in the back cover for details. The following diagram shows 
a single character A (01000001) as sent at 9600 baud. The top is from 
the PIC18F67J10, the bottom is from the MAX232, the 8 data bits are 
between the dotted lines. Each bit is 104µs.
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11 ADVANCED DEBUGGING

 RS-232 printf statements can be a good tool to help debug a program. It does, however, 
require an extra hardware setup to use. If the ICD is being used as a debug tool, the 
compiler can direct putc() and getc() through the debugger interface to the debugger 
screen. Add the following line to the end of the prototype.h fi le:

#use rs232 (DEBUGGER)

 Modify EX9.c to create EX11.c  by changing protoalone.h to prototype.h.
 Compile and load the program into the Prototyping board.
 Click GO, then click the Monitor tab.
 A prompt should appear. Enter some data to confi rm that the program is working.
 Stop and reset the program. 
 In PCW click Project>Open all fi les as an easy way to get all the project fi les open in IDE.
 Click the stdlib.h tab, and set a breakpoint in the atol() function on the line: 

result = 10*result + (c - ‘0’);

 This function is called from get_long() to convert a string to a number. This line is 
executed for each character in the string.

 Click the debugger Log tab, check the LOG box, set the breakpoint as 1 and expression 
as result. Result is the value of the number being converted.

 Click GO, then click the Monitor tab and enter 1234 enter. 
 Click the Log tab and notice that each time the breakpoint was hit the value of the result 

variable was logged.  In this case the breakpoint did not cause a full stop of the program, 
it just logged the value of the requested expression and kept on going.

 Stop the program.
 Delete the breakpoint by selecting the breakpoint and click on the  icon.
 Uncheck the LOG box under the log tab.
 Set a breakpoint on the last printf() in the program.
 Enter watches for a, b and result. 
 Click GO and enter two numbers and +.
 When the break is reached click on the snapshot icon: 
 Check Time and Watches, uncheck everything else.
 If a printer is connected to the PC select Printer, otherwise select Unique fi le.
 Click on the Now button.
 Notice the requested data (time and watches) are either printed or written to a fi le as 

requested.
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 Click on the snapshot icon again and this time select Append to file, put in a filename of 
EX11.txt and check After each single step.

 Check Last C line executed in addition to the Time and Watch selected already and 
close the snapshot window. 

 Reset and then Step Over until the final printf() is executed. Enter the data when 
requested.

 Use File>Open>Any File to find the file EX11.txt (by default in the Debugger Profiles 
directory) after setting the file type to all files.

 Notice the log of what happened with each step over command.
 Uncheck the After each single step in the snapshot window. 
 Clear the breakpoints and set a breakpoint on the switch.
 Click Reset then Go and enter the requested data using the + operator.
 When the break is reached click on the Peripherals tab and select Timer0.
 Shown will be the registers associated with timer0. Although this program does not use 

timer0 the timer is always running so there is a value in the TMR0 register. Write this 
value down. 

 Clear the breakpoints and set a breakpoint on the final printf().
 Click GO.
 Check the TMR0 register again. If the new value is higher than the previous value then 

subtract the previous value from the current value. Otherwise, add 256 to the current 
value and then subtract the previous value (because the timer flipped over). 

 The number we now have is the number of clock ticks it took to execute the switch and 
addition. A clock tick by default is 0.2µs. Multiply your number of ticks by 0.2 to find the 
time in µs. Note that the timers (and all peripherals) are frozen as soon as the program 
stops running.

 The debugger Eval tab can be used to evaluate a C expression. This 
includes assignments. Set a break before the switch statement and use the 
Eval window to change the operator being used.  For example, type a + but 
change it to a - before the switch. 

 Set a break on the switch statement and when reached, change to the 
C/ASM view and single step through the switch statement. Look up the 
instructions executed in the PIC18F67J10 data sheet to see how the switch 
statement is implemented. This implementation is dependent on the case 
items being close to each other. Change * to ~ and then see how the 
implementation changes.  

A
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FURTHER STUDY
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12 TIMERS

 The PIC18F67J10 has fi ve built-in timers. Each timer has a different set of features. The 
following example will use Timer #1 to measure the time it takes to execute some C code.

 Create the fi le EX12.c as follows: 

 Compile and Run the program. Check the monitor tab to see the result.

 This number is the number of timer ticks that it took to set and read the timer. The 
T1_INTERNAL indicates the instruction clock is the source for the timer. The instruction 
clock is the oscillator divided by four, or in our case, 0.2µs. This time represents the 
overhead of our timer code and may now be used in a more useful example.

 Modify the program as follows and replace the ??? with the number of ticks determined 
in the above program. 

#include <prototype.h>

void main() {
 long time;  

 setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
 set_timer1(0);

 time = get_timer1();
 printf(“Time in ticks is %lu\r\n”,time);   
}

#include <prototype.h>

void main() {
 long time;  
 long a,b,c;

 setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
 set_timer1(0);
 a=b*c;
 time = get_timer1();
 time -= ???; // subtract overhead
 printf(“Time is %lu microseconds.\r\n”,
  (time+2)/5);
}
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 Time the actual time for a delay_us(200) to see how accurate the compiler is.
 Make a program to time the addition operator for 8 bit, 16 bit, 32 bit and fl oating 

point.  Instead of int, the compiler allows the use of int8, int16 and int32 to 
specify the number of bits in an integer variable.

A
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 Since “time” represents the number of 0.2 microsecond ticks that it 

takes to do “a=b*c”, then time/5 is the number of microseconds it takes 
to do that one line of C code.  Use (time + 2)/5 to round instead of 
truncating.

 All the timers on the PIC18F67J10 count up and when the maximum 
value is reached, the timer restarts at 0.  The set_ timer1(0) resets the 
timer to 0.  Timer1 is 16 bits and the range is 0 to 65535.  This means 
it will overfl ow every 13107.2µs.  This is the largest time the program 
will be able to measure.

 If using T1_EXTERNAL instead of INTERNAL, then the timer would 
increment every time pin C0 cycled.  This makes it more of a counter.

 If using T1_DIV_BY_2 instead of  BY_1, then the timer would 
increment once for every 2 instruction clocks.  This makes the timer 
tick 0.4µs and the range of the timer is now 26214.4µs.

 The following is a summary of the timers on the PIC18F67J10 chip:
#0 Input is Instruction Clock or external pin 

Range is 0-255 or 0-65535
Input can be divided by 1,2,4,8,16,32,64,128,256
Can generate interrupt on each overfl ow

#1 Input is Instruction Clock or external pin 
Range is 0-65535
Input can be divided by 1,2,4,8
Can generate interrupt on each overfl ow

#2 Input is Instruction Clock only
Range can be programmed from 0-1 to 0-255
Input can be divided by 1,4,16
Can generate interrupt on 1-16 overfl ows

#3 Input is Instruction Clock or external pin
Range is 0-65535
Input can be divided by 1,2,4,8
Can generate interrupt on each overfl ow

#4 Input is Instruction Clock only
Range can be programmed by 0-1 to 0-255
Input can be divided by 1,4,16
Can generate input on 1-16 overfl ows
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13 INTERRUPTS

 An interrupt is a specifi c event that causes the normal program execution to be 
suspended wherever it is and an interrupt function is executed. Normal program 
execution continues when the interrupt function returns. The PIC18F67J10 has a number 
of interrupt sources such as a timer overfl ow, an incoming RS-232 character or a change 
on a pin.

 In this exercise, the timer1 overfl ow interrupt will be used to extend the timer1 timer from 
16 bits to 32 bits by counting the number of times the timer overfl ows. Create the fi le 
EX13.c as follows:

#include <prototype.h>

int16 overfl ow_count;

#int_timer1
void timer1_isr() {
 overfl ow_count++;
}

void main() {
 int32 time;  

 setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
   enable_interrupts(int_timer1);
 while(TRUE) {
  enable_interrupts(global);
  
  while(input(PUSH_BUTTON));// Wait for press 
  set_timer1(0);
  overfl ow_count=0;
   
  while(!input(PUSH_BUTTON));//Wait for release 
  disable_interrupts(global);
  time = get_timer1();
  time = time + ((int32)overfl ow_count<<16);
  time -= 15; // subtract overhead
  printf(“Time is %lu.%06lu seconds.\r\n”,
   time/5000000, (time/5)%1000000);
 }
}

 Compile and Run the program. Press the button, release, and note the time it was held 
down is shown to six decimal places in the Monitor pane. 
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 The interrupt function is designated by preceding it with #INT_TIMER1. 

A number of interrupt functions can be specifi ed by preceding each 
with the proper directive like #INT_EXT for the external interrupt pin 
(B0) or #INT_RDA for an incoming RS-232 character.

 An interrupt must be specifi cally enabled (via enable interrupts 
(specifi c interrupt)) and interrupts must be globally enabled (via 
enable_interrupts(GLOBAL)). The GLOBAL enable/disable controls 
whether any interrupts are serviced. 

 Notice interrupts are disabled before the timer is read and combined 
with the overfl ow count. This is done to prevent the following situation:
 The timer value is read and it is 65535
 The overfl ow interrupt happens and the counter is incremented to 1
 The program continues and reads the counter as 1
 The time is assumed to be 65536+65535 when in fact 
 the correct time is 65535

 If interrupts are disabled and an interrupt event happens, then the 
interrupt function will be called when interrupts are enabled. If multiple 
interrupt events of the same type happen while interrupts are disabled, 
then the interrupt function is called only once when interrupts are 
enabled. 

 The %06lu format specifi er is the same as %6lu except leading zeros 
are printed.

 Make a version of this program that prints in the format
 MM:SS.FFFFFF
Where MM is minutes, SS is seconds and FFFFFF is fractions of a second.

 Add a second interrupt using timer0 to interrupt every 13.1ms. In the interrupt 
routine, count interrupts and when 76 interrupts have happened, do a 
putc(‘.’);.  This should display a period every second while interrupts are 
enabled. 

A
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FURTHER STUDY
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USING THE BREADBOARD14
 The breadboard may be used to prototype 

circuits with components not on the 
Prototyping board. The black terminal 
block is used to connect jumpers from the 
Prototyping board to the breadboard. The 
breadboard has two columns on either 
side where all the holes in the column are 
connected. These are usually used for +5V 
and Ground. The inside of the breadboard 
is split down the center and the holes on 
either side are connected within the row. 
The gray shading on the right diagram 
shows how the holes are electrically 
connected. 

 This exercise will use an external serial EEPROM chip. Create the fi le EX14.c.

#include <protoalone.h>
#include <utility.c>
#include <9356.c>

void main() {
 int count;
  
 init_ext_eeprom();
 count = read_ext_eeprom(0);
 while(TRUE) {
  show_binary_on_leds(count);
  wait_for_one_press();
  count++;
  write_ext_eeprom(0,count);
 }
}
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 Wire up the circuit as shown in the following diagram. The diagram on the left shows  
how to route the wires. The schematic view below is how the remaining exercises in this 
booklet will show the wiring.

 Compile and Run the program.  Verify that when the program is halted, reset, and 
restarted, the count continues from where it left off. 

 To show your understanding of the breadboard, rewire this same circuit to 
use three less jumper wires.

 The functions to communicate with the 9356 chip are in 9356.c. Since the 
data in and data out pins are not used at the same time they can be the same 
pin. Modify the circuit and the 9356.c code so both data in and data out use 
the same pin on the PIC18F67J10.

A
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FURTHER STUDY
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15 CLOCKING DATA IN AND OUT

 Using the circuit from Exercise 14 enter, compile and test the following program to more 
easily test the serial EEPROM:

#include <protoalone.h>
#include <stdlib.h>
#include <input.c>
#include <9356.c>

void main() {
 int cmd, address;
   
 init_ext_eeprom();
   
 while(TRUE) {
  printf(“\n\n\rEnter address: “);
  address = get_int();
      
  do {
   printf(“\n\rRead or Write (R, W): “);
   cmd = toupper(getc());
  } while((cmd != ‘R’) && (cmd != ‘W’));
      
  if(cmd == ‘R’)
   printf(“\n\rValue is %u”,
    read_ext_eeprom(address));
  else if(cmd == ‘W’) {
   printf(“\n\rEnter data: “);
   write_ext_eeprom(address, get_int());
  }
 }
} 

 The 9356 device being used has four I/O 
connections as shown in this timing diagram. A 
diagram like this is typically found in the device 
datasheet. The transmission starts with CS 
going high on this chip. Then the chip expects 
the DI to change while the CLK line is low;  and 
it is safe to be read while the CLK is high. Note 
that the clock pulse before CS goes high is not 
required. Open the 93LC56 data sheet using  
Tools>Internet>Data sheets for Device Drivers.

CS

CLK

DI

DO

1 10

HIGH-Z
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 Table 1-4 in the data sheet outlines the command format. All commands 

start with a 1 and followed by a 2 or 3 bit command. Depending on the 
command there may then be eight address bits and eight data bits. 
Commands in total are either 12 or 20 bits.

 The following code makes the CS high, then clocks 20 bits of data out in 
accordance with the previous timing diagram. The data is kept in a three 
byte array called cmd.
 output_high (CS) ;
 for (i=1;i<=20;++i)  {
  output_bit(DI, shift_left(cmd,3,0) ;
  output_high(CLK) ;
  output_low(CLK) ;
 }

 The shift_left function shifts all the bits in cmd one position to the left. 
The 3 tells the function how many bytes are in cmd and the 0 is the bit 
value to shift into the lowest position. The bit shifted out of the highest 
position is returned from the function, and in this case then passed to 
output_bit. Output_bit() is like output_high/low except that the high/low is 
determined at run time by the second parameter.

 Open the 9356.c fi le in the drivers directory. Reviewing the code in 
write_ext_eeprom() you will see the code to issue a write command. 
When the shift is left, the fi rst byte transmitted is cmd[2].  Since there 
are 24 bits in cmd and we only need 20, there is an initial shift of four bits 
to line up before transmission.

 Figure 1-1 in the data sheet shows the required times between events. 
For example, the time from CS going high to CLK going high is labeled 
as Tcss. Table 1-2 shows Tcss needs to be at least 50ns. Not a problem 
in the code.

 Add a new command to the EX15 program to erase the entire EEPROM. Add 
a function erase_ext_eeprom() that uses the chip’s ERAL command.

 The write_ext_eeprom function in 9365.c has a 11ms delay at the end to wait 
for the write to complete. Make a new version of this function that, instead of 
a fi xed delay, uses the busy check feature described in the data sheet. 

A
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FURTHER STUDY
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16 USING AN I2C 
TEMPERATURE SENSOR

 The previous exercise used three to four wires to communicate serially to a chip. 
That method is generally referred to as SPI (Serial Port Interface). A popular two 
wire communications bus that allows multiple devices to use the same two wires was 
developed by Phillips and is called I²C. This exercise uses a temperature sensor that 
communicates via I²C. Enter the following simple program to use the temperature sensor. 

#include <prototype.h>
#include <ds1631.c>

void main() {
 fl oat value;

 init_temp();

 while(TRUE) {
  value = read_full_temp();
  value /= 100.0;
  printf(“%3.2f\n\r”, value);
  delay_ms(1000);
 }
}

 Because multiple devices can use the same two wires, no device ever drives the wires 
high. Pull-up resistors on the wires allow them to fl oat high and devices may ground the 
wire to make them low. The two wires are designated SDA and SCL. Using the DS1631 
chip wire up the following circuit:
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 Compile and Run the program. The monitor window should display the temperature 
every second. Hold your fi nger on the chip to raise the temperature reading. 
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 Since multiple devices are using the same two wires, each device on 
the bus has a 7-bit address. For the DS1631, four of the address bits 
are fi xed and the other three may be set via the A0, A1, and A2 pins. 
In our case we set them all to 0.  This means up to eight of these chips 
could be on the same two wire bus.

 Data is transferred over the bus by fi rst sending a unique pattern on 
the pins called a start condition. This is followed by the 7-bit address, 
and a bit to designate if data is to transfer to or from the master. The 
master in our case is the PIC18F67J10. This byte is followed by any 
number of data types and a stop condition. Some devices allow the 
data direction bit without a stop condition. The DS1631 requires a read 
command to be sent to it and then the data direction changes and two 
bytes are read from it. The following is an extract of the code from 
DS1631.C
 i2c_start() ; 
 i2c_write(0x90) ;     // Address and direction  
 i2c_write(0xaa) ;     // DS1631 command to read
 i2c_start() ;
 i2c_write(0x91) ;     // Address and direction
 datah=i2c_read();
 datal_i2c_read(0) ;
 i2c_stop();

 Make a version of this program that lights the green LED if the temperature is at 
or below 75, the yellow LED if it is 76-79 and the red LED when it is 80 and up.

 Each byte on the bus is acknowledged. I2C_WRITE returns a 0 if the byte was 
accepted. Make a new version of read_temp() that checks the result of the fi rst 
I2C_write() and displays an error if the byte was not accepted. Then change the 
address from 1001000x to 1001010x and note that the new error is displayed. 
Now change the hardware circuit to use the new address. 
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FURTHER STUDY
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17 DRIVING A 
7 SEGMENT LED DISPLAY

 7 Segment LED units are used as an easy way to display numbers. Each of the 7 
segments is an individual LED that can be turned on just as the LEDs on the Prototyping 
board. In order to save on I/O pins, it is common to multiplex the LED segments. In this 
case, there are two digits. Each segment is connected to the corresponding segment 
on the other digit. Only one digit is energized with the correct segments set. After a 
short period of time, that digit goes off and the other digit is lit with its segments on. By 
alternating very quickly, it will appear that both digits are on all the time and 9 I/O pins 
are used instead of 16. Connect up the following circuit to accomplish this goal:
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 Each segment is identifi ed with a designator like a1. Segment a is the top 
LED and 1 is the fi rst digit. To light this digit, power up pins 16 and 14. To 
light the same segment on digit 2 (a2) then power up pin 16 and 13.

 This example does not use the decimal points (DP1 and DP2).
 Unlike the onboard LEDs, there is no built-in current limiting resistor on 

these units. Many applications will require a series resistor on each of 
the segments. In this case, we use a high current LED and know that 
the PIC18F67J10 drive capability will ensure the LED segments are not 
damaged.
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 The following program will count from 1 to 99. Enter and run the program:

#include <protoalone.h>
  
byte CONST LED_MAP[10] =
{0x3f,0x06,0x5b,0x4f,0x66,0x6d,0x7d,0x07,0x7f,0x67};

void display_number( int n ) {
 output_b(LED_MAP[n/10]);
 output_low(PIN_C0);
 delay_ms(2);
 output_high(PIN_C0);
 output_b(LED_MAP[n%10]);
 output_low(PIN_C1);   
 delay_ms(2);
 output_high(PIN_C1);
}
  
void main() {
 int count=1,i;

 while(TRUE) {
  for(i=0;i<=200;i++)
   display_number(count);
  count = (count==99) ? 1 : count+1;
 }
}
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S  Unlike the previous programs, this program writes to all I/O pins on 
one port at the same time using output_b(). 

 The LED_MAP array specifi es for each number which segments need 
to be on.  The fi rst entry (zero) needs segments a, b, c, d, e, f on. This 
is B0-B5 or in hex 0x3F.

 The ? : notation was used to make it easy to change the increment 
value and range with just this one line.

 Make a version of this program that counts from 00-FF in hex. The hex digits 
A, b, C, d, E, F can be displayed using 7 segments.

 Use the DS1631 and this display to make a digital thermometer. 
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18 REAL-TIME INTERFACING

 Connect up the circuit to the right using the 
NJU6355 real-time clock chip. This chip 
can keep accurate date and time using 
the small crystal attached to the part. The 
interface to the PIC18F67J10 is an SPI 
interface. Internally the date/time is kept in 
the chip in BCD. 

 Enter and run the following program to demonstrate the real-time clock:

#include <protoalone.h>
#include <nju6355.c>
#include <stdlib.h>
#include <input.c>

void set_time(){
 int hour,min;
 printf(“\r\nHour: “);hour=get_int();
 printf(“\r\nMin: “);min=get_int();
 rtc_set_datetime(0,0,0,0,hour,min);
}

void main(){
 int hour,min,sec,last_sec;
 rtc_init();
 while(true){

  rtc_get_time(hour,min,sec);
  if(sec!=last_sec){
   printf(“\r\n%02u:%02u:%02u”,hour, min, sec);
   last_sec=sec;
  }
  if(kbhit()&&getc()==’S’)
   set_time();
 }
}

32 Khz
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port. The && operator evaluates left to right. This means if the kbhit() 
returns false, then the getc() is never called. If it were called, the pro-
gram would hang here (because there was no character). This effect is 
referred to as a short circuit. Not all languages guarantee this, how-
ever, ANSI C does.

 Make a version of this program that starts by asking for an alarm hour and 
minute. When the alarm time is reached light the red LED. 

 Update the program to do both date and time. See the NJU6355.c fi le for 
help on the parameters to rtc_set_datetime().

A

B

FURTHER STUDY
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19 POWER MANAGED MODES FOR
THE PIC18F67J10

 The PIC18F67J10 supports the various modes for the sake of managing power in an 
application. The three primary modes of operation are:

  • Run mode:  The clock to the CPU are peripherals are active.
 • Idle mode:  This mode selectively inactivates the CPU clock while the peripheral  
   clocks continue to operate. 
 • Sleep mode:  All clock sources are inactive. This mode performs at the lowest   
   current consumption of the device (only leakage current).

 Once the device is in idle or sleep mode, it needs to wake-up to start performing its 
normal operation. The following events can wake-up the CPU from idle or sleep mode:

  •  WDT Time-out
 •  RESET
 •  Interrupt

 Selecting a power managed mode requires two decisions:
  • Is the CPU to be clocked or not?

 • Which clock source is to be used?

 In the Sleep mode, the CPU and peripheral clocks are shut down and this mode achieves 
the lowest current consumption. The example in this chapter will put the chip in sleep 
mode and use a WDT Time-out to wake-up the chip.

 The Sleep mode is ideal for battery powered devices. The PIC18F67J10 prototyping 
board can be powered up through the 9V jack or a standard 9V battery. A jumper is used 
to select the power between the power jack and the battery. 

 The example in this chapterwill put the chip into Sleep mode after performing a specifi ed 
operation. The chip will remain in sleep mode until a wake-up event, like a watch dog 
timer reset (WDT), occurs. To reduce power consumption in the sleep mode, the on-
board LEDs must be turned off. Setup the watchdog timer using the #fuses directive in 
the protoalone.h fi le. Replace the line with #fuses directive with the line below.

#fuses HS, WDT, WDT512

 The ‘WDT’ in the # fuses directive will enable the watch dog timer. The watch dog timer 
runs on an on-chip Internal Oscillator of 31 Khz to produce a base time of 4 ms. The 
‘WDT512’ in #fuses directive is used to set the postscaler to 1:512 which gives a reset 
time of approximately two seconds. The UART_ENABLE pins control the power to the 
on-board RS232 level converter, the DS276.

 Type in the following code into utility.c. Flash the LED’s on the board and enter low power 
mode before executing the Sleep instruction.
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void TurnOFFLEDs()
{
   output_high(GREEN_LED);
   output_high(YELLOW_LED);
   output_high(RED_LED);

}

void fl ash_one_LED(int led)
{
   TurnOFFLEDs();
   delay_ms(500);
   light_one_led(LED);
   delay_ms(500);
   TurnOFFLEDs();
   delay_ms(500);
   light_one_led(LED);
   delay_ms(500);
   TurnOFFLEDs();
}

void EnterPowerSaveMode()
{
TurnOFFLEDs();
}

 Flash the LEDs on the board and enter low power mode before exectuing the Sleep 
instruction.

 The example used to demonstrate the power save mode is similar to Ex7. An analog 
value is read from the potentiometer connected to pin A0 and an LED is fl ashed based an 
A/D reading. The chip is put into sleep mode and will wake-up when the watch dog timer 
expires. The chip can also be awakened by manually resetting by pressing the Reset 
button.

 Type in the following sample program and save as EX19.c. This example will read the 
analog pin A0 and fl ash the corresponding LED before entering into sleep mode.
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#include <protoalone.h>
 #include <utility.c>
 
 #defi ne cutoff 128
 #defi ne neutral_zone 25

 void main() {
     int8 reading;;
     restart_wdt();
   
     setup_adc_ports(AN0);
     setup_adc(adc_clock_internal);
     set_adc_channel( 0 );
     delay_ms(100);
     reading = read_adc();
    
        if(reading<(cutoff-neutral_zone/2))
           fl ash_one_LED(GREEN);
           else if (reading>(cutoff+neutral_zone/2))
        fl ash_one_LED(RED);
          else
           fl ash_one_LED(YELLOW);
         
         EnterPowerSaveMode();
         sleep();
 }

 Compile the program and download onto the chip using Tools>ICD.

 Disconnect the power from the prototyping board and then the ICD from the prototyping 
board.

 Connect the jumper for the battery powered mode. Connect the 9V battery to board.
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 Modify EX19.c so that the chip will sleep for one minute before it takes the 
next analog reading. Make changes to the #fuses directive and select the 
correct postscaler value to get the correct timing. 

 Modify EX19 to incorporate the DS1631 I2C temperature sensor. Measure 
the temperature every one minute and display it on one of the serial ports.

A

B

FURTHER STUDY

 Press the Reset button and the program will start running. Note that an LED will flash 
based on the position of the knob before the chip goes into sleep mode. Change the 
position of the knob to verify that the chip flashes another LED when it wakes up. The 
time for which the chip is in sleep mode depends on the watch dog time postscaler which 
can be set using the #fuses directive. The power-up timer on the chip holds the chip in 
reset after the watch dog timer has expired, so the actual sleep time is longer than what 
the WDT postscaler will set. The board consumes about 4 mA in Run mode and less than 
400 µA when in Sleep mode.
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Troubleshooting
 The MCLR pin must be in a high state for the chip to run.  Note the Prototyping board 

schematic uses a pushbutton to ground this pin and to reset the chip.

 Most problems involve the clock.  Make sure the confi guration fuses are set to the proper 
oscillator setting.  In the above case, for a 20MHz crystal HS (High Speed) is the proper 
setting.  In the above circuit, the size of the resistor may need adjustment depending 
upon the crystal.

 If the program does not seem to be running, verify 3.3 volts on the MCLR pin and the fi ve 
power pins.

 Isolate hardware problems from fi rmware problems by running a program with the 
following at the start of main ( ) and check B0 with a logic probe or scope:

 while(TRUE)   {
  output_low (PIN_B0);
  delay_ms (1000);
  output_high (PIN_B0);
  delay_ms (1000);
 }

The following diagram is a somewhat minimal circuit for a PIC18F67J10
 Notice this chip has fi ve +3.3V and ground connections.  Some chips have only one of 

each.  A 0.1µf capacitor mounted near the chip is a good idea and one on either side of 
the chip is even better.  This will reduce noise both to and from the chip.

 The clock circuit here uses a crystal.  With many high speed crystals the resistor on 
clock out prevents the crystal from being driven.  The capacitor values used are generally 
specifi ed in the crystal specifi cation sheets.  The PIC18F67J10 data sheet will show a 
number of other options for the clock.

#20
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MIGRATING TO YOUR 
OWN HARDWARE
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The In-Circuit Progamming/Debugging Interface
 To program and/or debug in circuit, two I/O pins (B6, B7) are reserved.  If debugging is 

not to be done, then these pins may also be used in the target circuit.  However, care 
must be taken to ensure the target circuit has high impedance during programming.

 The B3 pin is optional and is not used for programming.  However, the Monitor feature 
of the debugger does use B3.  It is possible to program and debug (without monitor) and 
allocate B3 to the target hardware.  In this case do not connect B3 to the ICD connector.

 Note that the ICD to target cable reverses the pins so the MCLR signal is ICD pin 6 and 
that connects to the target pin 1.

1  2  3  4  5  6

Vdd

Vdd

47K

MCLR

PGD (usually B7)
PGC (usually B6)
B3 (optional)

VSS

Target ICD connector
Looking into the connector

PIC



This booklet is not intended to be a tutorial for the PIC18F67J10 or the C programming language. 
It does attempt  to cover the basic use and operation of the development tools. There are 
some helpful tips and techniques covered, however, this is far from complete instruction on C 
programming. For the reader not using this as a part of a class and without prior C experience the 
following references should help. 

Exercise PICmicro® MCU C: An introduction to 
Programming the Microchip PIC® in CCS 
by Nigel Gardner

The C Programming Language by 
Brian W. Kernighan and Dennis M. 
Ritchie (2nd ed.)

3 1.1 The structure of C Programs
1.2 Components of a C Program
1.3 main()
1.5 #include
1.8 constants
1.11 Macros
1.13 Hardware Compatibility
5.5 While loop
9.1 Inputs and Outputs

1.1 Getting Started
1.4 Symbolic Constants
3.1 Statements and Blockx
3.5 Loops
1.11 The C Preprocessor

4 1.7 Variables
1.10 Functions
2.1 Data Types
2.2 Variable Declaration
2.3 Variable Assignment
2.4 Enumeration
3.1 Functions
3.4 Using Function Arguments
4.2 Relational Operators
5.7 Nesting Program Control Statements
5.10 Switch Statement

1.2 Variables and Arithmetic Expr
2.1 Variable Names
2.2 Data Types and Sizes
2.3 Constants
2.4 Declarations
2.6 Relational and Logical Operators
3.4 Switch
1.7 Functions
1.8 Arguments
4.1 Basics of Functions

5 4.3 Logical Operators
4.4 Bitwise Operators
4.5 Increment and Decrement
5.1 if Statements
5.2 if-else Statements
9.3 Advanced BIT Manipulation

3.2 if-Else
2.8 Increment and Decrement Ops
2.90 Bitwise Operators

6 4.1 Arithmetic Operators 2.5 Arithmetic Operators

7 9.5 A/D Conversion 3.3 Else

References



8 5.4 For Loop
6.1 One-Dimensional Arrays

1.3 The For Statement
1.6 Arrays
2.10 Assignments Operators and Exp

9
1.6 printf Function
9.6 Data Comms/RS-232

1.5 Character Input and Output
2.6 Loops-Do-While
7.1 Standard Input and Output
7.2 Formatted Output - printf

12 9.4 Timers

13 2.6 Type Conversion
9.11 Interrupts

2.7 Type Conversions

15 9.8 SPI Communications
16 9.7 I2C Communications

17 5.2 ? Operator 2.11 Conditional Expressions
18 4.6 Precedence of Operators 2.12 Precedence and Order Eval

Comprehensive list of PIC® MCU 
Development tools and information www.mcuspace.com

Microchip Home Page www.microchip.com

CCS Compiler/Tools Home Page www.ccsinfo.com

CCS Compiler/Tools Software Update Page www.ccsinfo.com
click: Support → Downloads

C Compiler User Message Exchange www.ccsinfo.com/forum

Device Datasheets List www.ccsinfo.com
click: Support → Device Datasheets

C Compiler Technical Support support@ccsinfo.com

On The Web



Other Development Tools

EMULATORS
The ICD used in this booklet uses two I/O pins on the chip to communicate with a small 
debug program in the chip. This is a basic debug tool that takes up some of the chip’s 
resources (I/O pins and memory). An emulator replaces the chip with a special connector 
that connects to a unit that emulates the chip. The debugging works in a simulator manner 
except that the chip has all of its normal resources, the debugger runs faster and there are 
more debug features. For example an emulator typically will allow any number of breakpoints. 
Some of the emulators can break on an external event like some signal on the target board 
changing. Some emulators can break on an external event like some that were executed 
before a breakpoint was reached. Emulators cost between $500 and $3000 depending on the 
chips they cover and the features.

DEVICE PROGRAMMERS
The ICD can be used to program FLASH chips as was done in these exercises. A stand 
alone device programmer may be used to program all the chips. These programmers will 
use the .HEX fi le output from the compiler to do the programming. Many standard EEPROM 
programmers do know how to program the Microchip parts. There are a large number of 
Microchip only device programmers in the $100-$200 price range. Note that some chips 
can be programmed once (OTP) and some parts need to be erased under a UV light before 
they can be re-programmed (Windowed). CCS offers the Mach X which is a stand-alone 
programmer and can be used as an in-circuit debugger.

PROTOTYPING BOARDS
There are a large number of Prototyping boards available from a number of sources. 
Some have an ICD interface and others simply have a socket for a chip that is externally 
programmed.  Some boards have some advanced functionality on the board to help design 
complex software. For example, CCS has a Prototyping board with a full 56K modem on 
board and a TCP/IP stack chip ready to run internet applications such as an e-mail sending 
program or a mini web server. Another Prototyping board from CCS has a USB interface chip, 
making it easy to start developing USB application programs.

SIMULATORS
A simulator is a program that runs on the PC and pretends to be a microcontroller chip. 
A simulator offers all the normal debug capability such as single stepping and looking at 
variables, however there is no interaction with real hardware. This works well if you want to 
test a math function but not so good if you want to test an interface to another chip. With the 
availability of low cost tools, such as the ICD in this kit, there is less interest in simulators. 
Microchip offers a free simulator that can be downloaded from their web site. Some other 
vendors offer simulators as a part of their development packages.



CCS Programmer Control Software

The CCSLOAD software will work for all the CCS device programmers and replaces the 
older ICD.EXE and MACHX.EXE software. The CCSLOAD software is stand-alone and 
does not require any other software on the PC. CCSLOAD supports ICD-Sxx, ICD-Uxx, 
Mach X, Load-n-Go, and PRIME8.

Powerful Command Line Options in Windows and Linux
· Specify operational settings at the execution level

 · Set-up software to perform, tasks like save, set target Vdd
 · Preset with operational or control settings for user
Easy to use Production Interface

· Simply point, click and program 
 · Additions to HEX fi le organization include associating comments or a graphic image  
   to a fi le to better ensure proper fi le selection for programming
 · Hands-Free mode auto programs each time a new target is connected to the programmer
 · PC audio cues indicate success and fail
Extensive Diagnostics

· Each target pin connection can be individually tested
 · Programming and debugging is tested with known good programs
 · Various PC driver tests to identify specifi c driver installation problems
Enhanced Security Options
 · Erase chips that failed programming
 · Verify protected code cannot be read after programming
 · File wide CRC checking
Automatic Serial Numbering Options
 · Program memory or Data EEPROM
 · Incremented, from a fi le list or by user prompt
 · Binary, ASCII string or UNICODE string
CCS IDE owners can use the CCSLOAD program with:
 · MPLAB®ICD 2/ICD 3
 · MPLAB®REAL ICE™

· All CCS programmers and debuggers
How to Get Started:
Step 1: Connect Programmer to PC and target board.  Software will auto-detect the   
 programmer and device.
Step 2: Select Hex File for target board.  
Step 3: Select Test Target.  Status bar will show current progress of the operation.
Step 4: Click “Write to Chip” to program the device.

Use the Diagnostics tab for troubleshooting or the ccsload.chm help fi le for additional assistance.
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