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1 UNPACKING AND INSTALLATION

CCS, Inc.

Inventory
 Use of this kit requires a PC with Windows 95, 98, ME, NT, 2000 or XP.  The PC must 

have a spare 9-Pin Serial or USB port, a CD-ROM drive and 75 MB of disk space.

 The diagram on the following page shows each component in the PIC16F1937 kit.  
Ensure every item is present.

Software
 Insert the CD into the computer and wait for the installation program to start.  If your 

computer is not set up to auto-run CDs, then select My Computer and double click on 
the CD drive.

 Click on Install and use the default settings for all subsequent prompts by clicking NEXT, 
OK, CONTINUE…as required.

 Identify a directory to be used for the programs in this booklet. The installation program 
will create an empty directory c:\program fi les\picc\projects that may be used for this 
purpose.

 Select the compiler icon on the desktop. In the PCW IDE, click Help>About and verify 
a version number is shown for the IDE and PCM to ensure the software was installed 
properly. Exit the software.

Hardware
 Connect the PC to the ICD(6) using the USB cable.(1) Connect the prototyping board (10) to 

the ICD using the modular cable.  Plug in the AC adaptor (9) to the power socket and plug 
it into the prototyping board (10). The fi rst time the ICD-U is connected to the PC, Windows 
will detect new hardware. Install the USB driver from the CD or website using the new 
hardware wizard. The driver needs to be installed properly before the device can be used.

 The LED should be red(2) on the ICD-U to indicate the unit is connected properly.

 Run the Programmer Control Software by clicking on the CCSLOAD icon on the desktop. 
Use CCSLOAD Help File for assistance. 

 The software will auto-detect the programmer and target board and the LED should be 
illuminated green. If any errors are detected, go to Diagnostic tab. If all tests pass, the 
hardware is installed properly.

 Disconnect the hardware until you are ready for Chapter 3. Always disconnect the power 
to the Prototyping board before connecting/disconnecting the ICD or changing the 
jumper wires to the Prototyping board. 
(1) ICS-S40 can also be used in place of ICD-U.  Connect it to an available serial port on the PC using the 9 
pin serial cable.  There is no driver required for S40. 

(2) ICD-U40 units will be dimly illuminated green and may blink while connecting.
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1 Storage box
2 Exercise booklet
3 CD-ROM of C compiler (optional)
4 Serial PC to Prototyping board cable
5 Modular ICD to Prototyping board cable
6 ICD unit for programming and debugging
7 Parts box includes: 

    93LC56 serial EEPROM chip
    DS1631 digital thermometer chip
    NJU6355 real-time clock chip with attached 32kHz crystal
    Two 1K resistors
    Jumpers to connect the Prototyping board to the breadboard
 8 USB (or Serial) PC to ICD cable
 9 AC Adaptor (9VDC)
10 Prototyping board with a PIC16F1937 processor chip 

  (See inside front and back covers for details on the board layout and schematic)
11 Breadboard for prototyping circuits
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Editor
 Open the PCW IDE. If any fi les are open, click File>Close All

 Click File>Open>Source File. Select the fi le: c:\program fi les\picc\examples\ex_
stwt.c

 Scroll down to the bottom of this fi le. Notice the editor shows comments, preprocessor 
directives and C keywords in different colors. 

 Click on the set_timer0 function and press F1. Notice a Help fi le description for set_
timer0 appears. The cursor may be placed on any keyword or built-in function and F1 will 
fi nd help for the item.

 Review the editor special functions by clicking on Edit. The IDE allows various standard 
cut, paste and copy functions. 

 Review the editor option settings by clicking on Options>Editor Properties. The 
IDE allows selection of the tab size, editor colors, fonts, and many more.  Click on 
Options>Toolbar to select which icons appear on the toolbars. 

Compiler
 Use the drop-down box under Compile to select the compiler. CCS offers different 

compilers for each family of Microchip parts. All the exercises in this booklet are for the 
PIC16F1937 chip, a 14-bit opcode part. Make sure PCM 14 bit is selected in the drop-
down box under the Compile tab.

 The main program being compiled is always shown in the bottom of the IDE. If this is not 
the fi le you want to compile, click on the tab of the fi le you want to compile, right click in 
the editor, and select Make fi le project.

 Click Options>Project Options>Include Files… and review the list of directories 
the compiler uses to search for included fi les. The install program should have put two 
directories in this list: devices and drivers.

 Normally the fi le formats need not be changed and global defi nes are not used in these 
exercises. To review these settings, click Options>Project Options>Output Files and 
Options>Project Options>Global Defi nes.

 Click the compile icon to compile. Notice the compilation box shows the fi les created 
and the amount of ROM and RAM used by this program. Press any key to remove the 
compilation box.

CCS, Inc.
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Viewer
 Click Compile>Symbol Map. This file shows how the RAM in the microcontroller is used. 

Identifiers that start with @ are compiler generated variables. Notice some locations are 
used by more than one item. This is because those variables are not active at the same time. 

 Click Compile>C/ASM List. This file shows the original C code and the assembly code 
generated for the C. Scroll down to the line: 
  int_count=INTS_PER_SECOND;

 Notice there are two assembly instructions generated. The first loads 4C into the W 
register. INTS_PER_SECOND is #defined in the file to 76. 4C hex is 76 decimal. The 
second instruction moves W into memory. Switch to the Symbol Map to find the memory 
location where int_count is located.

 Click View>Data Sheet, then View. This brings up the Microchip data sheet for the 
microprocessor being used in the current project.

Click here for the file menu.  Files and Projects are created, 
opened, or closed using this menu.

Place cursor here for slide out boxes.  
All of the current project’s source and 
output files can be seen here.

Compile ribbon.

Place cursor over each icon 
and press F1 for help.

Click the help icon for 
the help menu.  The technical 
support wizard and download 
manager are accessed using 
this menu.

Compiles current selected unit, does NOT link/build  
into a HEX file.

Quick view of supported devices.

Compiles all units that have changed since last build,  
links/builds into a HEX file.

Compiles all units regardless if they have changed since 
last build, links/builds into a HEX file.

PIC16F1937 Exercise Book



#include <16F1937.h>
#device ICD = TRUE
#fuses HS, PLL_SW, NOLVP, NOWDT
#use DELAY(CLOCK = 10000000)

#defi ne GREEN_LED  PIN_D0

void main(void) {
   while(TRUE) {
      output_low(GREEN_LED);
      delay_ms(1000);
      output_high(GREEN_LED);
      delay_ms(1000);
   }
}
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 The fi rst four lines of this program defi ne the basic hardware environ-
ment.  The chip being used is the PIC16F1937, running at 10MHz with 
the ICD debugger.

 The #defi ne is used to enhance readability by referring to GREEN_LED 
in the program instead of PIN_D0.

 The “while (TRUE)” is a simple way to create a loop that never stops.

 Note that the “output_low” turns the LED on because the other end of 
the LED is +5V. This is done because the chip can tolerate more current 
when a pin is low than when it is high.

 The “delay_ms(1000)” is a one second delay (1000 milliseconds).

CCS, Inc.

 Open the PCW IDE. If any fi les are open, click File>Close All

 Click File>New>Source File and enter the fi lename EX3.C

 Type in the following program and Compile.

COMPILING AND 
RUNNING A PROGRAM3



 Connect the ICD to the Prototyping board using the modular cable, and connect the 
ICD to the PC. Power up the Prototyping board.

 Click Debug>Enable Debugger and wait for the program to load. 

 If you are using the ICD-U and the debugger cannot communicate with the ICD unit, go 
to the Debug Configure tab and make sure ICD-USB from the list box is selected. 

 Click the green go icon: 

 Expect the debugger window status block to turn yellow, indicating the program is 
running. 

 The green LED on the Prototyping board should be flashing. One second on and one 
second off. 

 The program can be stopped by clicking on the stop icon:  

 Modify the program to light the green LED for 5 seconds, the 
yellow for 1 second and the red for 5 seconds. 

 Add to the program a #define  macro called “delay_seconds” so the  
delay_ms(1000) can be replaced with : delay_seconds(1); and  
delay_ms(5000) can be: delay_seconds(5);.

Note: Name these new programs EX3A.c and EX3B.c and follow the same 
 naming convention throughout this booklet.

A

B

FURTHER STUDY

ICD-U64
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 Type in and save the following program as EX4.c, compile and run:

4 HANDLING INPUT
Type in and save the following program as , compile and run:
#include <16F1937.h>
#device ICD = TRUE
#fuses HS, PLL_SW, NOLVP, NOWDT
#use DELAY(CLOCK = 10000000)

#defi ne GREEN_LED      PIN_D0
#defi ne YELLOW_LED     PIN_D1
#defi ne RED_LED        PIN_D2

#defi ne TOP_BUTTON     PIN_C4
#defi ne BOTTOM_BUTTON  PIN_C3
//
void light_one_led(int led {
   output_high(GREEN_LED);
   output_high(YELLOW_LED);
   output_high(RED_LED);
   
   switch(led) {
      case 0:
         output_low(GREEN_LED);
         break;
      case 1:
         output_low(YELLOW_LED);
         break;
      case 2:
         output_low(RED_LED);
         break;
   }
}

void wait_for_one_press(void) {
   while(input(TOP_BUTTON));
   while(!input(TOP_BUTTON));
}

void main(void) {
   while(TRUE) {
      light_one_led(0);
      wait_for_one_press();
      light_one_led(1);
      wait_for_one_press();
      light_one_led(2);
      wait_for_one_press();
   }
}

 As can be seen from the program, pressing the top push button will cycle through the 
LEDs: green, yellow, then red.

 Add the following new type below the // lines:
 typedef enum  {GREEN,YELLOW,RED}  colors;

CCS, Inc.
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 The Prototyping board has two momentary push-buttons that may be 
used as inputs to the program. The input pin is connected to a 4.7K 
pull-up resistor to +5V. The button, when pressed, shorts the input pin 
to ground. The pin is normally high while in this confi guration, but it is 
low while the button is pressed.

 This program shows how to use simple C functions. The function 
wait_for_one_press() will fi rst get stuck in a loop while the input pin 
is high (not pressed). It then waits in another loop while the pin is low. 
The function returns as soon as the pin goes high again. Note that 
the loops, since they do not do anything while waiting, do not look like 
much, they are a simple ; (do nothing).

 When the button is pressed once, it is common for several very quick 
connect/disconnect cycles to occur. This can cause the LEDs to 
advance more than once for each press. A simple debounce algorithm 
can fi x the problem. Add the following line between the two while 
loops: delay_ms(100); The following scope picture of a button press 
depicts the problem:

Modify the program so that while the top button is held down, the LEDs 
alternate as fast as possible. When the top button is not pressed, the LED 
state freezes. This creates a random color program.

A

FURTHER STUDY

 Change the parameter of light_one_led( ) to colors instead of int. 

 Change the 0, 1, 2 in the call light_one_led( ) to GREEN, YELLOW, RED.

PIC16F1937 Exercise Book



 It is good practice to put all the hardware defi nitions for a given design into a common fi le 
that can be reused by all programs for that board. Open EX4.C and highlight the fi rst nine 
lines of code in the fi le. Click Edit>Paste to fi le and name it prototype.h.

 It is also helpful to create a library of utility functions to use as needed for future 
programs. Note that just because a function is part of a program, it does not mean 
it takes up memory. The compiler deletes functions that are not used. Highlight the 
wait_for_one_press() function, light_one_led( ) function and the typedef line (if added 
from Chapter 4) and save as a new fi le named utility.c. 

 Open utility.c and add the following new function to the fi le:

 Close all fi les. Type in and save the following program as EX5.c.

PROGRAM STRUCTURE5

CCS, Inc.

#include “prototype.h”
#include “utility.c”

void main(void) {
   int count = 0;
   
   while(TRUE) {
      show_binary_on_leds(count);
      wait_for_one_press();
      count++;
   }
}

void show_binary_on_leds(int n) {
   output_high(GREEN_LED);
   output_high(YELLOW_LED);
   output_high(RED_LED);
   
   if(bit_test(n, 2)) {
      output_low(GREEN_LED);
   }
   if(bit_test(n, 1)) {
      output_low(YELLOW_LED);
   }
   if(bit_test(n, 0)) {
      output_low(RED_LED);
   }
}
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 In C, a function must either appear in the input stream before it is used OR 
it must have a prototype. A prototype is the part of the function defi nition 
before the “{“. In a program where main calls function A and function A 
calls function B, the order in the fi le must be B, A, MAIN. As an alternative, 
have Ap, Bp, MAIN, A, B where Ap and Bp are prototypes.  Frequently, 
prototypes are put into a header fi le with a .h extension

 The scope, initialization, and life of C variables depend on where and how 
they are declared. The following is a non-inclusive summary of the 
common variable scopes. Note that if a variable has an initialization (like 
int a=1;), the assignment happens each time the variable comes to life.

 Compile and Run the program. Check that 
with each press of the top push button the 
LEDs increment in the binary number pattern 
shown here.

Modify the program to increment the binary number every second without using 
the push buttons.
Instead of the built-in function BIT_TEST, modify the program to use standard C 
operators (such as & and ==) to test the bits.

A

B

FURTHER STUDY

0 0 0 0
0 0 1 1
0 1 0 2
0 1 1 3
1 0 0 4
1 0 1 5
1 1 0 6
1 1 1 7

Where it is defi ned Can be accessed Life of the variable
Inside a function Only in that function While function is alive
Inside a function with 
STATIC Only in that function During the entire run of 

the program

Outside all functions In any function defi ned 
afterwards in the fi le

During the entire run of 
the program

After “{“ inside a 
function

Only between the “{“ 
and corresponding “}”

Only up to the 
corresponding “}”

PIC16F1937 Exercise Book



 Open EX5.C and start the debugger Debug>Enable Debugger.

 Click the reset icon  to ensure the target is ready.

 Click the step-over icon  twice. This is the step over command. Each click causes a 
line of C code to be executed. The highlighted line has not been executed, but is about to 
be executed. 

 Step over the show _ binary _ on _ leds(count); line and notice that one click 
executed the entire function. This is the way step over works. Click step over on 
wait _ for _ one _ press();. Press the top push button and notice the debugger now 
stops since the function terminates. 

 Click the Watches tab, then the add icon  to add a watch. Enter count or choose 
count the variables from list, then click Add Watch. Notice the value shown. Continue 
to step over through the loop a few more times (press the button as required) and notice 
the count watch increments.

 Step over until the call to show _ binary _ on _ leds(count); is highlighted. This 
time, instead of step over, use the standard step icon  several times and notice the 
debugger is now stepping into the function.

 Click the GO icon  to allow the program to run. Press the top push button a couple 
of times to verify that the program is running normally. Click the stop icon  to halt 
execution. Notice the C source line that the program stopped on. This is the line were the 
program is waiting for a button press. 

 In the editor, click on show _ binary _ on _ leds(count); to move the editor cursor 
to that line. Then click the Breaks tab and click the add  icon  to set a breakpoint. 
The debugger will now stop every time that line is reached in the code. Click the GO icon 
and then press the top push button. The debugger should now stop on the breakpoint. 
Repeat this a couple of times to see how the breakpoint works. Note that the ICD with 
PIC16 chips only allow one breakpoint at a time.

 Click Compile>C/ASM list. Scroll down to the highlighted line. Notice that one assembly 
instruction was already executed for the next line. This is another side effect of the ICD 
debugger. Sometimes breakpoints skip by one ASM instruction. 

 Click the step over icon a few times and note that when the list fi le is the selected 
window, the debugger has executed one assembly instruction per click instead of one 
entire C line.

 Close all fi les and type in and save the following program as EX6.c.

6 DEBUGGING

CCS, Inc.



 Compile the program and step-over until c=a+b is executed. Add a Watch for c, the 
expected value is 16.

 Step-over the subtraction and notice the value of c. The int data type by default is 
not signed, so c cannot be the expected –6. The modular arithmetic works like a car 
odometer when the car is in reverse only in binary. For example, 00000001 minus 1 is 
00000000, subtract another 1 and you get 11111111.

 Reset and again step up to the c=a+b. Click the Eval tab. This pane allows a one time 
expression evaluation. Type in a+b and click Eval to see the debugger calculate the 
result. The complete expression may also be put in the watch pane as well. Now enter 
b=10 and click Eval. This expression will actually change the value of B if the “keep side 
effects” box of the evaluation tab is checked.  Check it and click Eval again. Step over 
the addition line and click the Watches tab to observe the c value was calculated with 
the new value of b. 

Modify the program to include the following C operators to see how they work:         
 *   /   %   &   ^ 
Then, with b=2 try these operators: >>  <<
Finally, try the unary complement operator with: c=~a;
Design a program to test the results of the relational operators:
 <     >     = =    !=
by exercising them with b as 10, 11, and 12.
Then, try the logical operators || and && with the four combinations of a=0,1 
and b=0,1.
Finally, try the unary not operator with: c=!a; when a is 0 and 1.

A

B

FURTHER STUDY
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#include “prototype.h”
#include “utility.c”

void main(void) {
   int a, b, c;
   
   a = 11;
   b = 5;
   c = a + b;
   c = b - a;
   
   while(TRUE);
}
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 Compile and Run the program. Verify that the Prototyping board knob (A0) is turned so 
the green LED is on when it is low, the red LED when high and the yellow LED for a small 
region in the center.

7 ANALOG TO DIGITAL CONVERSION

2.5V

0V 5V

 The PIC16F1937 chip has 14 pins that may be used to read an analog voltage. These 14 
pins can be confi gured to certain combinations of analog input and digital pins, but not all 
combinations are possible.

 Type in the following program to read a single analog pin and save as EX7.c.

CCS, Inc.

Compile and Run the program. Verify that the Prototyping board knob (A0) is turned so 

#include “prototype.h”
#include “utility.c”

#defi ne CUTOFF        128
#defi ne NEUTRAL_ZONE  25

void main(void) {
   int reading;
   
   setup_adc_ports(sAN0);
   setup_adc(ADC_CLOCK_INTERNAL);
   set_adc_channel(0);
   
   while(TRUE) {
      reading = read_adc();
      
      if(reading < (CUTOFF - (NEUTRAL_ZONE / 2))) {
         light_one_led(GREEN);
      } else if(reading > (CUTOFF + (NEUTRAL_ZONE / 2))) {
         light_one_led(RED);
      } else {
         light_one_led(YELLOW);
      }
   }
}



Modify the program to use a long variable for reading. Open prototype.h and 
change #device to:
 #device ICD=TRUE, ADC = 16
This will change the range to 0-65535.  Change the constant in the program to 
refl ect the new range. When the above example is complete, remove the ADC=16 
so it will default to ADC=8

Write a timer program that will light the green LED for x seconds after pressing the 
top button. x should be 0-25, depending on the setting of the analog knob.

A

B

FURTHER STUDY
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 By default, the analog to digital converter is 8 bits. Thus, a range of 0 to 

5 volts analog is represented by the numbers 0-255. The A/D reading 
can be converted to volts by the formula:
  Volts = reading*(5.0/255)

 The setup_adc_ports( ) function call determines what pins are set to 
be analog inputs. The setup_adc( ) function call determines how fast 
the conversion is done. The internal clock option uses an internal RC 
clock. Although the timing is not exact, it is long enough for an accurate 
conversion. The time can be based off the instruction clock for more 
precise timing.

 The set_adc_channel( ) function sets the A/D converter to channel 0 
(AN0 or A0). This switches an internal mux in the port, but does not 
start an A/D conversion. Even though a conversion has not started, 
there is a small capacitor in the chip that must charge up after the port 
switch and before the voltage is read. This is fast with a low impedance 
input, but for a higher impedance input, a small delay should be put in 
after the channel is changed.

 The call to read_adc starts a conversion, waits for it to complete and 
returns the result. The conversion time is around 20us.

PIC16F1937 Exercise Book



 The following program modifi es EX7.c to display the average voltage reading over 10 
seconds on the LEDs. Make the changes and save as EX8.c.

8 ARRAYS AND ANALOG FILTERING

CCS, Inc.

#include “prototype.h”
#include “utility.c”

#defi ne CUTOFF        128
#defi ne NEUTRAL_ZONE  25

void main(void) {
   int i, count = 0, history_ptr = 0;
   int history[10];
   long reading;
   
   setup_adc_ports(sAN0);
   setup_adc(ADC_CLOCK_INTERNAL);
   set_adc_channel(0);
   
   while(TRUE) {
      reading = 0;
      delay_ms(1000);
      history[history_ptr++] = read_adc();
      
      if(history_ptr == 10) {
         count = history_ptr;
         history_ptr = 0;
      } else {
         if(count < 10) {
            count = history_ptr;
         }
      }
      
      for(i = 0; i < count; i++) {
         reading += history[i];
      }
      
      reading /= count;
      
      if(reading < (CUTOFF - (NEUTRAL_ZONE / 2))) {
         light_one_led(GREEN);
      } else if(reading > (CUTOFF + (NEUTRAL_ZONE / 2))) {
         light_one_led(RED);
      } else {
         light_one_led(YELLOW);
      }
   }
}



 Compile and Run the program and confi rm that the movement of the knob takes a few 
seconds to appear on the LEDs. Furthermore, confi rm that a quick movement of the knob 
from high to low makes no difference in the LEDs.
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 This program uses several of the C shortcut operators.  For example, the 
 reading += history[i] is the same as 
  reading = reading + history[i]
 and history[history _ ptr++] = read _ adc(); is the same as
  history[history _ ptr] = read _ adc();
  history _ ptr = history _ ptr+1;

 A C array declared history[10] means the valid subscripts are history[0] 
through history[9].

 The reading variable needs to be a long (16 bits) because the largest 
value 255*10 is larger than 8 bit int.

 The history variable can be placed in the watch list and then when the 
program is halted, the debugger will show all the points in history being 
used to make up the fi ltered reading.

Modify the program to keep all LEDs off until 10 samples are obtained.
Modify the program to handle the LEDs differently on even and odd cycles as 
follows:
 Even: Show the actual last reading on the LED.
 Odd:  If the last reading is the same as the averaged reading, show 
  this on the LEDs.  Otherwise, turn all LEDs off.
The LED fl ashes after a change, and when the reading is stable, the LED 
will be solid.

A
B

FURTHER STUDY
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 When EX5.c was executed, it would always begin counting at 0. The program can be 
modifi ed to continue counting where it left off when restarted. This is done by saving the 
count value in the PIC16F1937 internal data EEPROM. This memory retains the data 
even when power is removed.  

 Type in and save the following program as EX9.c.

 Compile and Run the program. Verify that when the program is halted, reset, and 
restarted that the count continues where it left off.

STAND-ALONE PROGRAMS
AND EEPROM
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 The fi rst argument to read/write_eeprom( ) is the address in the EE-
PROM to write the byte to. The PIC16F1937 part ranges from 0 to 255, 
allowing 256 bytes to be saved. The second argument in write_eeprom 
is the value to write.

 There is a limit to how many times a given location in the data EEPROM 
can be written to. For example, the PIC16F877 chip allows 100,000 
times and the A version of this chip may allow 10 times that amount.  
For this reason, a program should be designed not to write any more 
often than is necessary. For example, if the volume setting for a TV is 
being saved, one might wait until there are no changes for 5 seconds 
before saving a new value to EEPROM. Some system designs can give 
early warning on power down and the program can only save to 
EEPROM at power down.

9
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Compile and Run the program. Verify that when the program is halted, reset, and 

#include “prototype.h”
#include “utility.c”

void main(void) {
   int count;
   
   count = read_eeprom(0);
   
   while(TRUE) {
      show_binary_on_leds(count);
      wait_for_one_press();
      count++;
      write_eeprom(0, count);
   }
}



 Close the debug window.

 Copy the prototype.h file to a new file named protoalone.h, and remove the following line: 
 #device ICD=TRUE

 This allows the program to run as a stand-alone, which does not require the ICD to run.

 Modify EX9.c to use protoalone.h. Compile the program, then click Tools>CCSLOAD 
to load the program onto the Prototyping board.

 Disconnect the power from the Prototyping board, then disconnect the ICD from the 
Prototyping board.

 Power up only the Prototyping board and verify the program runs correctly.

 Press the reset button on the Prototyping board and release. The LEDs should go off 
while in reset, then the program will restart.

  Modify EX7.c so that the cut-off point is a variable and that variable is kept in 
EEPROM location 100. Establish a new cut-off point whenever the top button is 
pressed to wherever the knob is set. Be careful to only write the EEPROM once 
per press.

 Modify the EX9.c program so that 10 EEPROM locations are used and each 
time the button is pressed only one of the 10 locations is written to and the 
location changes with each press. This will extend the life of this unit by 10 
times, if it were a real product.  

  Hint:  The count value could be the sum of all 10 locations %8.
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 RS-232 is a popular serial communications standard used on most PCs and many 
embedded systems. Two wires are used (in addition to ground), one for outgoing data 
and one for incoming data. The PIC16F1937 chip has built-in hardware to buffer the 
serial data if pins C6 and C7 are used. The compiler will allow any pins to be used and 
will take advantage of the built-in hardware if you pick those pins. Add the following line 
to the end of protoalone.h:

#use rs232 (baud=9600, xmit=PIN _ C6, rcv=PIN _ C7)  

 Type in and save the following program as EX10.c.

10 USING AN RS-232 PORT
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Type in and save the following program as 
#include “protoalone.h”
#include “utility.c”
#include <stdlib.h>
#include <input.c>

void main(void) {
   char operation;
   long a, b, result;
   
   while(TRUE) {
      printf(“\r\nEnter the fi rst number: “);
      a = get_long();
      
      do {
         printf(“\r\nEnter the operator (+-*/): “);
         operation = getc();
         putc(operation);
      } while(!isamong(operation, “+-*/”));
      
      printf(“\r\nEnter the second number: “);
      b = get_long();
      
      switch(operation) {
         case ‘+’:
            result = a + b;
            break;
         case ‘-’:
            result = a - b;
            break;
         case ‘*’:
            result = a * b;
            break;
         case ‘/’:
            result = a / b;
            break;
      }
      
      printf(“\r\nThe result is: %lu\r\n”, result);
   }
}



 Compile and Load the program into the Prototyping board.

 Connect the Prototyping board to the PC as shown below.

 At the PC, close the debugger window and start the program Tools>Serial Port 
Monitor.  Set the correct COMM port and BAUD rate if necessary.

 Power up the Prototyping board and a prompt at the PC should appear.  Enter a number 
followed by the enter key, an operator (like +) and another number followed by enter.  
Verify the result is shown correctly.  

N
O

T
E

S

 The basic functions for RS-232 are putc() and getc(). printf calls putc() 
multiple times to output a whole string and format numbers if request-
ed.  get_long() is a function in input.c to read a long number by calling 
getc() many times.  See input.c for other functions such as get_int() and 
get_string().

 The % in the printf indicates another parameter is included in the printf 
call and it should be formatted as requested.  %lu indicates to format as 
an unsigned long.

 getc() will cause the program to stop and wait for a character to come in 
before it returns.

Modify to add the operators: % | & ^
Modify to use fl oat instead of long.  You will need to do get_fl oat() instead 
of get_long() and use the format specifi cier %9.4f to get 4 digits after the 
decimal place.
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 Type in and save the following program as EX11.c:

 Compile and Load the program onto the Prototyping board.

 Power up the board and use the serial port monitor to test.

11 MORE RS-232 AND 
USING STRUCTURES
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Compile and Load the program onto the Prototyping board.

#include “protoalone.h”
#include “utility.c”

#defi ne MAX  3

struct animal {
   char code;
   char name[8];
   int count;
};

struct animal animals[MAX] = 
   {{‘A’, “Ants”, 0}, {‘B’, “Birds”, 0}, {‘C’, “Cats”, 0}};

int fi nd(char code, int & index) {
   for(index = 0; index < MAX; index++) {
      if(animals[index].code == code) {
         return(TRUE);
      }
   }
   return(FALSE);
}

void main(void) {
   char code;
   int index;
   
   while(TRUE) {
      printf(“\r\nEnter the code: “);
      code = getc();
      putc(code);
      
      if(fi nd(code, index)) {
         animals[index].count++;
         printf(“\r\nYou now have: %u %s\r\n”,
            animals[index].count, animals[index].name);
      } else {
         printf(“\r\nCode not valid\r\n”);
      }
   }
}
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 The int & index is our fi rst example with an output parameter to a 

function.  The & indicates the value is returned to the caller (actually the 
callers copy of the variable is used).

 At a hardware level, RS-232 sends a series of bits. The baud = option 
specifi es how many bits are sent per second. The bit stream, as 
specifi ed above, is a start bit (always 0), 8 data bits (lsb fi rst) and a 
stop bit (always 1). The line then remains at the 1 level. The number of 
bits may be changed with a bits= option and a parity bit can be added 
before the stop bit with a parity= option. A 0 is represented as a positive 
voltage (+3 to +12V) and a 1 is represented as a negative voltage (-3 to 
–12V). Since the PIC16F1937 outputs only 0V and 5V, a level converter 
is required to interface to standard RS-232, devices such as a PC.  A 
popular chip that does this is the MAX232. (See schematic on back 
cover for details) The following diagram shows a single character A 
(01000001) as sent at 9600 baud. The top is from the PIC16F1937, the 
bottom is from the MAX232, the 8 data bits are between the dotted lines. 
Each bit is 104µs.

Modify the program to keep the counts in a separate (from the structure) 
array.  Then add the CONST keyword before animals to put this data in ROM 
instead of RAM.  Compare the memory usage for both programs.  
If there is room, modify to add new entries when the code is not found.  Set 
MAX to 6 and add a new variable to keep track of the number of entries.
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 RS-232 printf statements can be a good tool to help debug a program. It does, however, 
require an extra hardware setup to use. If the ICD is being used as a debug tool, the 
compiler can direct putc() and getc() through the debugger interface to the debugger 
screen. Add the following line to the end of the prototype.h fi le:

  #use rs232 (DEBUGGER)

 Modify EX10.c to create EX12.c  by changing protoalone.h to prototype.h.
 Compile and Load the program into the Prototyping board.
 Under the Debug Confi gure tab, change Userstream Enable to true and Echo on 

Monitor to false and click Apply. 
 Click GO, then click the Monitor tab.
 A prompt should appear. Enter some data to confi rm that the program is working.
 Stop and reset the program. 
 In PCW click Project>Open all fi les as an easy way to get all the project fi les 

open in IDE.
 Click the stdlib.h tab, and set a breakpoint in the atol() function on the line: 
  result = 10*result + (c - ‘0’);

 This function is called from get_long() to convert a string to a number. This line is 
executed for each character in the string.

 Click the debugger Break Log tab, check the LOG box, set the breakpoint as 1 and 
expression as result. Result is the value of the number being converted.

 Click GO, then click the Monitor tab and enter 1234 enter. 
 Click the Log tab and notice that each time the breakpoint was hit the value of the result 

variable was logged.  In this case the breakpoint did not cause a full stop of the program, 
it just logged the value of the requested expression and kept on going.

 Stop the program.
 Delete the breakpoint by selecting the breakpoint and click on the  icon.
 Uncheck the LOG box under the log tab.
 Set a breakpoint on the last printf() in the program.
 Enter watches for a, b and result. 
 Click GO and enter two numbers and +.
 When the break is reached click on the snapshot icon: 
 Check Time and Watches, uncheck everything else.
 If a printer is connected to the PC select Printer, otherwise select Unique fi le.
 Click on the Now button.

12 ADVANCED DEBUGGING
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The debugger Eval tab can be used to evaluate a C expression. This includes 
assignments. Set a break before the switch statement and use the Eval window 
to change the operator being used. For example, type a + but change it to a 
- before the switch. 
Set a break on the switch statement and when reached, change to the C/ASM 
view and single step through the switch statement. Look up the instructions 
executed in the PIC16F1937 data sheet to see how the switch statement is 
implemented. This implementation is dependent on the case items being close 
to each other. Change * to ~ and then see how the implementation changes.  
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 Notice the requested data (time and watches) are either printed or written to a file as requested.
 Click on the snapshot icon again and this time select Append to file, put in a filename of 

EX12.TXT and check After each single step.
 Check Last C line executed in addition to the Time and Watch selected already and 

close the snapshot window. 
 Reset and then Step Over until the final printf() is executed. Enter the data when requested.
 Use File>Open>Any File to find the file EX12.TXT (by default in the Debugger Profiles 

directory) after setting the file type to all files.
 Notice the log of what happened with each step over command.
 Uncheck the After each single step in the snapshot window. 
 Clear the breakpoints and set a breakpoint on the switch.
 Add the following line to the program before the while loop and Compile and Run the 

program, entering the requested data:
   setup _ timer _ 0 (RTCC _ INTERNAL);

 When the break is reached click on the Peripherals tab and select Timer 0.
 Shown will be the registers associated with timer 0. Although this program does not use timer 

0 the timer is always running so there is a value in the TMR0 register. Write this value down. 
 Clear the breakpoints and set a breakpoint on the final printf().
 Click GO.
 Check the TMR0 register again. If the new value is higher than the previous value then 

subtract the previous value from the current value. Otherwise, add 256 to the current 
value and then subtract the previous value (because the timer flipped over). 

 The number we now have is the number of clock ticks it took to execute the switch and 
addition. A clock tick by default is 0.4µs. Multiply your number of ticks by 0.4 to find the 
time in µs. Note that the timers (and all peripherals) are frozen as soon as the program 
stops running.
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 The PIC16F1937 has fi ve built-in timers. Each timer has a different set of features. The 
following example will use Timer #1 to measure the time it takes to execute some C code.

 Type in and save the following program as EX13.c: 

 Compile and Run the program. Check the monitor tab to see the result.

 This number is the number of timer ticks that it took to set and read the timer. The 
T1_INTERNAL indicates the instruction clock is the source for the timer. The instruction 
clock is the oscillator divided by 4, or in our case, 0.4us. This time represents the 
overhead of our timer code and may now be used in a more useful example.

 Modify the program as follows and replace the ??? with the number of ticks determined 
in the above program. 

TIMERS13
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#include “prototype.h”

void main(void) {
   long time;
   
   setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
   set_timer1(0);
   
   time = get_timer1();
   printf(“Time in ticks is %lu\r\n”, time);
}

#include “prototype.h”

void main(void) {
   long time, a, b, c;
   
   setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
   set_timer1(0);
   
   a = b * c;
   time = get_timer1();
   time -= ???;
   printf(“Time: %lu microseconds\r\n”, ((2 * (time + 2)) / 5));
}



#0 Input is Instruction Clock or external pin 
Range is 0-255
Input can be divided by 1,2,4,8,16,32,64,128,256
Can generate interrupt on each overfl ow

#1 Input is Instruction Clock or external pin 
Range is 0-65535
Input can be divided by 1,2,4,8
Can generate interrupt on each overfl ow

#2
#4
#6

Input is Instruction Clock only
Range can be programmed from 0-1 to 0-255
Input can be divided by 1,4,16
Can generate interrupt on 1-16 overfl ows
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 Since “time” represents the number of 0.4 microsecond ticks that it takes 

to do “a=b*c”, then time/5 is the number of microseconds it takes to do 
that one line of C code. Use (time + 2)/5 to round instead of truncating.

 All the timers on the PIC16F1937 count up and when the maximum 
value is reached, the timer restarts at 0. The set_ timer1(0) resets the 
timer to 0. Timer 1 is 16 bits and the range is 0 to 65535. This means it 
will overfl ow every 26214.4µs. This is the largest time the program will 
be able to measure.

 If using T1_EXTERNAL instead of INTERNAL, then the timer would 
increment every time pin C0 cycled. This makes it more of a counter.

 If using T1_DIV_BY_2 instead of  BY_1, then the timer would increment 
once for every 2 instruction clocks. This makes the timer tick 0.8µs and 
the range of the timer is now 52428.8µs.

 The following is a summary of the timers on the PIC16F1937 chip:

Modify the program to time the actual time for a delay_us(200) to see how 
accurate the compiler is.
Make a program to time the addition operator for 8 bit, 16 bit, 32 bit and fl oating 
point.  Instead of int, the compiler allows the use of int8, int16 and int32 to 
specify the number of bits in an integer variable.
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 An interrupt is a specifi c event that causes the normal program execution to be 
suspended wherever it is and an interrupt function is executed. Normal program 
execution continues when the interrupt function returns. The PIC16F1937 has a number 
of interrupt sources such as a timer overfl ow, an incoming RS-232 character or a change 
on a pin.

 In this exercise, the timer 1 overfl ow interrupt will be used to extend the timer 1 timer 
from 16 bits to 32 bits by counting the number of times the timer overfl ows. Type in and 
save the following program as EX14.c:

 Compile and Run the program. Press the top button, release, and note that the time it 
was held down is shown to 6 decimal places in the monitor pane. 

14 INTERRUPTS
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#include “prototype.h”

int16 overfl ow_count;

#int_timer1
void timer1_isr(void) {
   overfl ow_count++;
}

void main(void) {
   int32 time;
   
   setup_timer_1(T1_INTERNAL | T1_DIV_BY_1);
   enable_interrupts(int_timer1);
   
   while(TRUE) {
      enable_interrupts(global);
      while(input(TOP_BUTTON));
      set_timer1(0);
      overfl ow_count = 0;
      while(!input(TOP_BUTTON));
      disable_interrupts(global);
      
      time = get_timer1();
      time += ((int32)overfl ow_count << 16);
      time -= 15;
      printf(“Time: %lu.%06lu seconds\r\n”,
         ((2 * time) / 5000000), (((2 * time) / 5) % 1000000));
   }
}
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 The interrupt function is designated by preceding it with #INT_TIMER1. 

A number of interrupt functions can be specifi ed by preceding each with 
the proper directive like #INT_EXT for the external interrupt pin (B0) or 
#INT_RDA for an incoming RS-232 character.

 An interrupt must be specifi cally enabled (via enable_interrupts 
(specifi c interrupt)) and interrupts must be globally enabled 
(via enable_interrupts(GLOBAL)). The GLOBAL enable/disable 
controls whether any interrupts are serviced. 

 Notice interrupts are disabled before the timer is read and combined with 
the overfl ow count. This is done to prevent the following situation:
 The timer value is read and it is 65535
 The overfl ow interrupt happens and the counter is incremented to 1
 The program continues and reads the counter as 1
 The time is assumed to be 65536+65535 when in fact the 
 correct time is 65535

 If interrupts are disabled and an interrupt event happens, then the inter-
rupt function will be called when interrupts are enabled. If multiple inter-
rupt events of the same type happen while interrupts are disabled, then 
the interrupt function is called only once when interrupts are enabled. 

 The %06lu format specifi er is the same as %6lu except leading zeros are 
printed.

Make a version of this program that prints in the format
   MM:SS.FFFFFF
 Where MM is minutes, SS is seconds and FFFFFF is fractions of a second.
B Add a second interrupt using timer 0 to interrupt every 13.1ms. In the 

interrupt routine, count interrupts and when 76 interrupts have happened, do 
a putc(‘.’);. This should display a period every second while interrupts are 
enabled. 
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 The breadboard may be used to prototype 
circuits with components not on the Prototyping 
board. The black terminal block is used to 
connect jumpers from the Prototyping board 
to the breadboard. The breadboard has two 
columns on either side where all the holes in 
the column are connected. These are usually 
used for +5V and Ground. The inside of the 
breadboard is split down the center and the 
holes on either side are connected within the row.

 This exercise will use an external serial EEPROM chip. Type in and save the following 
program as EX15.c

USING THE BREADBOARD15
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#include “protoalone.h”
#include “utility.c”

#defi ne EEPROM_SELECT  PIN_A1
#defi ne EEPROM_CLK     PIN_A3
#defi ne EEPROM_DI      PIN_B1
#defi ne EEPROM_DO      PIN_B2

#include <9356.c>

void main(void) {
   int count;
   
   init_ext_eeprom();
   count = read_ext_eeprom(0);
   
   while(TRUE) {
      show_binary_on_leds(count);
      wait_for_one_press();
      count++;
      write_ext_eeprom(0, count);
   }
}



 Wire the circuit as shown in the following diagram. The diagram on the left shows  
how to route the wires. The schematic view on the right is how the remaining exercises in 
the booklet will show the wiring.

Compile and Run the program. Test the program like EX9. 

To show your understanding of the breadboard, rewire this same circuit to 
use 4 less jumper wires.
The functions to communicate with the 9356 chip are in the 9356.c file. Since 
the data in and data out pins are not used at the same time, they can be the 
same pin. Modify the circuit and the 9356 code so both data in and data out 
use the same pin on the PIC16F1937. 
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 Using the circuit from Exercise 15 enter, compile and test the following program to more 
easily test the serial EEPROM:

 The 9356 device being used has 4 I/O connections 
as shown in this timing diagram. A diagram like 
this is typically found in the device datasheet. The 
transmission starts with CS going high on this chip. 
Then the chip expects the DI to change while the 
CLK line is low;  and it is safe to be read while the 
CLK is high. Note that the clock pulse before CS 
goes high is not required.

16 CLOCKING DATA IN AND OUT
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#include “protoalone.h”
#include <stdlib.h>
#include <input.c>

#defi ne EEPROM_SELECT  PIN_A1
#defi ne EEPROM_CLK     PIN_A3
#defi ne EEPROM_DI      PIN_B1
#defi ne EEPROM_DO      PIN_B2

#include <9356.c>

void main(void) {
   int cmd, address;
   
   init_ext_eeprom();
   
   while(TRUE) {
      printf(“\n\n\rEnter Address: “);
      address = get_int();
      
      do {
         printf(“\n\rRead or Write (R, W): “);
         cmd = toupper(getc());
         putc(cmd);
      } while((cmd != ‘R’) && (cmd != ‘W’));
      
      if(cmd == ‘R’) {
         printf(“\n\rValue: 0x%X”, read_ext_eeprom(address));
      } else {
         printf(“\n\rEnter Data: “);
         write_ext_eeprom(address, get_int());
      }
   }
}
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 Table 1-4 in the data sheet outlines the command format. All commands 

start with a 1 and followed by a 2 or 3 bit command. Depending on the 
command there may then be 8 address bits and 8 data bits. Commands 
in total are either 12 or 20 bits.

 The following code makes the CS high, then clocks 20 bits of data out in 
accordance with the previous timing diagram. The data is kept in a three 
byte array called cmd.
  output_high (CS) ;
  for (i=1;i<=20;++i)  {
   output_bit(DI, shift_left(cmd,3,0) ;
   output_high(CLK) ;
   output_low(CLK) ;
  }

 The shift_left function shifts all the bits in cmd one position to the left. 
The 3 tells the function how many bytes are in cmd and the 0 is the bit 
value to shift into the lowest position. The bit shifted out of the highest 
position is returned from the function, and in this case then passed to 
output_bit. Output_bit() is like output_high/low except that the high/low 
is determined at run time by the second parameter.

 Open the 9356.c fi le in the drivers directory. Reviewing the code in 
write_ext_eeprom() you will see the code to issue a write command. 
When the shift is left, the fi rst byte transmitted is cmd[2].  Since there 
are 24 bits in cmd and we only need 20, there is an initial shift of 4 bits 
to line up before transmission.

 Figure 1-1 in the data sheet shows the required times between events. 
For example, the time from CS going high to CLK going high is labeled 
as Tcss. Table 1-2 shows Tcss needs to be at least 50ns. Not a problem 
in the code.

Add a new command program to erase the entire EEPROM. Add a function 
erase_ext_eeprom() that uses the chip’s ERAL command.
The write_ext_eeprom function in 9365.c has a 11ms delay at the end to wait 
for the write to complete. Make a new version of this function that, instead of 
a fi xed delay, uses the busy check feature described in the data sheet. 
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 The previous exercise used 3-4 wires to communicate serially to a chip. That method is 
generally referred to as SPI (Serial Port Interface). A popular 2 wire communications bus 
that allows multiple devices to use the same two wires was developed by Phillips and is 
called I²C. This exercise uses a temperature sensor that communicates via I²C. Type in 
and save the follwoing program as EX17.c:

 Because multiple devices can use the same two wires, no device ever drives the wires 
high. Pull-up resistors on the wires allow them to fl oat high and devices may ground the 
wire to make them low. The two wires are designated SDA and SCL. Using the DS1631 
chip wire up the following circuit:

17 USING AN I2C 
TEMPERATURE SENSOR

#include “prototype.h”

#defi ne DAL_SCL PIN_A3
#defi ne DAL_SDA PIN_A1

#include <DS1631.c>

void main(void) {
   fl oat value;
   
   init_temp();
   
   while(TRUE) {
      value = read_full_temp();
      value /= 100.0;
      printf(“%3.2f\n\r”, value);
      delay_ms(1000);
   }
}
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 Compile and Run the program. The monitor window should display the temperature 
every second. Hold your fi nger on the chip to raise the temperature reading. 
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 Since multiple devices are using the same two wires, each device on 
the bus has a 7 bit address. For the DS1631, four of the address bits 
are fi xed and the other three may be set via the A0, A1, and A2 pins. 
In our case we set them all to 0. This means up to eight of these chips 
could be on the same two wire bus.

 Data is transferred over the bus by fi rst sending a unique pattern on the 
pins called a start condition. This is followed by the 7 bit address, and a 
bit to designate if data is to transfer to or from the master. The master in 
our case is the PIC16F1937. This byte is followed by any number of data 
bytes and a stop condition. Some devices allow the data direction bit to 
change without a stop condition. The DS1631 requires a read command 
to be sent to it and then the data direction changes and two bytes are 
read from it. The following is an extract of the code from DS1631.C

 i2c_start() ; 
 i2c_write(0x90) ;     // Address and direction
 i2c_write(0xaa) ;     // DS1631 command to read
 i2c_start() ;
 i2c_write(0x91) ;     // Address and direction
 datah=i2c_read();
 datal_i2c_read(0) ;
 i2c_stop();

Make a version of this program that lights the green LED if the temperature is at 
or below 75, the yellow LED if it is 76-79, and the red LED when it is 80 and up.
Each byte on the bus is acknowledged. I2C_WRITE returns a 0 if the byte was 
accepted. Make a new version of read_temp() that checks the result of the fi rst 
I2C_write() and displays an error if the byte was not accepted. Then change the 
address from 1001000x to 1001010x and note that the new error is displayed. 
Now change the hardware circuit to use the new address. 

A

B

FURTHER STUDY
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 Connect the circuit to the right using the 
NJU6355 real-time clock chip. This chip 
can keep accurate date and time using 
the small crystal attached to the part. 
The interface to the PIC16F1937 is an 
SPI interface. Internally the date/time is 
kept in the chip in BCD. 

 Type in and save the following program as EX18.c:

#include “protoalone.h”
#include <stdlib.h>
#include <input.c>

#defi ne RTC_DATA  PIN_A3
#defi ne RTC_CLK   PIN_B1
#defi ne RTC_CE    PIN_B2
#defi ne RTC_IO    PIN_A1

#include <NJU6355.c>

void set_time(void) {
   int hour, min;
   
   printf(“\n\rHour: “);
   hour = get_int();
   printf(“\n\rMinute: “);
   min = get_int();
   
   rtc_set_datetime(0, 0, 0, 0, hour, min);
}

void main(void) {
   int hour, min, sec, last_sec;
   
   rtc_init();
   
   while(TRUE) {
      rtc_get_time(hour, min, sec);
      
      if(sec != last_sec) {
         printf(“\n\r%02u:%02u:%02u”, hour, min, sec);
         last_sec = sec;
      }
      
      if(kbhit() && (getc() == ‘S’)) {
         set_time();
      }
   }
}
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Make a version of this program that starts by asking for an alarm hour and 
minute. When the alarm time is reached light the red LED. 
Update the program to do both date and time. See the NJU6355.c fi le for 
help on the parameters to rtc_set_datetime().

A

B

FURTHER STUDY

N
O

TE
S  The kbhit() function returns true if a character comes in the RS-232 

port. The && operator evaluates left to right. This means if the kbhit() 
returns false, then the getc() is never called. If it were called, the pro-
gram would hang here (because there was no character). This effect is 
referred to as a short circuit. Not all languages guarantee this, however, 
ANSI C does.
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 The PIC16F1937 includes a Liquid Crystal Display (LCD) Driver Module that controls the 
outputs to a number of segment and common pins and displays characters or numbers 
on a Segment LCD using timing signals generated by the module.

 The LCD Driver Module has a number of registers that control the operation of the 
Segment LCD by specifying the modes, clock signals, contrast, and other functions as 
described in the table below:

 The LCD Driver Module controls a number of segment and common pins which are 
driven by clock signals generated by the module to control the segments on the LCD. 
The segment pins of the module are connected to the segment pins on the LCD and the 
common pins are the grounds connected to the segments on the LCD. Using an LCD 
setup with multiple common pins allows for more segments on the LCD to be controlled 
with fewer segment pins connecting them to the module.

 Depending on the setup of the common pins on the LCD, this will determine the 
multiplexing mode to be used to control the LCD. The multiplex mode helps the driver 
module determine how to generate the clock signals on the segment and common pins to 
control multiple segments on the LCD using only one set of pins. The table below shows 
how many segment pins the PIC16F1937 can control depending on the multiplex mode:

19 INTRODUCTION TO THE SEGMENT 
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Register Register Functions

LCDCON Confi gures operation of the LCD modes.

LCDCST Confi gures contrast level of the LCD segments.

LCSPS Confi gures waveform type and LCD clock prescaler.

LCDREF Confi gures voltage references and LCD voltage pins.

LCDRL Confi gures internal reference ladder.

LCDSEn Confi gures port pins used for the LCD segments.

LCDDATAx Controls operation of the individual LCD segments.

Multiplex Mode Number of Segments Controlled

Static 24

1 / 2 48

1 / 3 72

1 / 4 96

 Depending on which multiplex mode is selected, the bias mode will also need to be 
selected. The bias mode determines the voltage levels to be used to determine the on 
and off states for the segments on the LCD.

 The prototyping board in the MiniPICD1937 Development Kit includes an external 4.5 
Digit 7-Segment LCD. It functions in 1/3 multiplex mode which means it uses 3 common 
pins and 12 segment pins to control the segment on the LCD.



 Create an lcd.c fi le and type in the following code, which will be used to display numbers 
on the Segment LCD:

#defi ne DIGIT4  COM0+3,  COM0+5,  COM1+5,  COM2+3,  COM1+0,  COM0+0,  COM1+3,  COM2+0
#defi ne DIGIT3  COM0+16, COM0+17, COM1+17, COM2+16, COM1+10, COM0+10, COM1+16, COM2+10
#defi ne DIGIT2  COM0+19, COM0+20, COM1+20, COM2+19, COM1+18, COM0+18, COM1+19, COM2+18
#defi ne DIGIT1  COM0+22, COM0+23, COM1+23, COM2+22, COM1+21, COM0+21, COM1+22, COM2+21

//               Digit 5    “-”      LB      CON                             
       //
#defi ne SPECIAL  COM2+5, COM2+17, COM2+20, COM2+23

//                                  Character Maps                           
       //
//                         0     1     2     3     4     5     6     7     8     
9  //
BYTE const digits[10] = {0xFC, 0x60, 0xDA, 0xF2, 0x66, 0xB6, 0xBE, 0xE0, 
0xFE, 0xE6};

#defi ne BLANK  0x00

BYTE lcd_position;

void lcd_display(char c) {
   BYTE segment;
   
   if(c == ‘\f’) {
      lcd_position = 0;
   } else {
      if((c >= ‘0’) && (c <= ‘9’)) {
         segment = digits[c - ‘0’];
      } else {
         segment = BLANK;
      }
      
      switch(lcd_position) {
         case 1:
            lcd_symbol(segment, DIGIT4);
            break;
         case 2:
            lcd_symbol(segment, DIGIT3);
            break;
         case 3:
            lcd_symbol(segment, DIGIT2);
            break;
         case 4:
            lcd_symbol(segment, DIGIT1);
            break;
      }
   }
   lcd_position++;
}
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 Type in and save the following program as EX19.c:

#include “protoalone.h”
#include “lcd.c”

void main(void) {
   long count = 0;
   
   setup_lcd(LCD_MUX13 | LCD_REF_ENABLED | LCD_B_HIGH_POWER, 0, 
0xFF0429);
   lcd_contrast(7);
   
   while(TRUE) {
      printf(lcd_display, “\f%4lu”, count);
      
      if(count++ == 10000) {
         count = 0;
      }
      
      delay_ms(50);
   }
}

 Compile and Run the program and verify that it counts from 0-9999 before resetting to 0.

CCS, Inc.
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 The following program will use the DS1631 temperature sensor and the Segment LCD to 
create a digital thermometer.

 Add the following functions to the lcd.c fi le:

20 USING THE SEGMENT LCD

void lcd_sign(signed long reading) {
   char digit5 = 0x00;
   
   if((reading < -999) || (reading > 999)) {
      digit5 |= 0x80;
   }
   if(reading < 0) {
      digit5 |= 0x40;
   }
   if((reading < -1999) || (reading > 1999)) {
      digit5 |= 0x10;
   }
   
   lcd_symbol(digit5, SPECIAL);
}

void lcd_digit(char c) {
   BYTE segment;
   printf(“%X, “, c);
   if(c == ‘\f’) {
      lcd_position = -2;
   } else {
      if((c >= ‘0’) && (c <= ‘9’)) {
         segment = digits[c - ‘0’];
      } else {
         segment = BLANK;
      }
      
      switch(lcd_position) {
         case 1:
            lcd_symbol(segment, DIGIT4);
            break;
         case 2:
            lcd_symbol(segment, DIGIT3);
            break;
         case 3:
            lcd_symbol(segment, DIGIT2);
            break;
      }
   }
   lcd_position++;
}

void lcd_degree(char temp) {
   char degree = 0x00;
   
   if(temp == ‘F’) {
      degree = 0x8E;
   }
   
   lcd_symbol(degree, DIGIT1);
}
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 Type in and save the following program as EX20.c:

 Connect the DS1631 as in Exercise #17.

 Compile and Run the program.

 Verify that the program displays the current temperature reading in °F and that the 
temperature will update while holding your fi nger on the DS1631.

#include “protoalone.h”
#include “lcd.c”

#defi ne DAL_SCL PIN_A3
#defi ne DAL_SDA PIN_A1

#include <DS1631.c>

void main(void) {
   long temperature;
   
   init_temp();
   
   setup_lcd(LCD_MUX13 | LCD_REF_ENABLED | LCD_B_HIGH_POWER, 0, 
0xFF0429);
   lcd_contrast(7);
   
   while(TRUE) {
      temperature = read_full_temp();
      temperature /= 100.0;
      
      printf(lcd_sign, “%c”, temperature);
      printf(lcd_digit, “\f%5ld”, temperature);
      printf(lcd_degree, “%c”, ‘F’);
   }
}

CCS, Inc.
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Troubleshooting
 The MCLR pin must be in a high state for the chip to run.  Note the Prototyping board 

schematic uses a pushbutton to ground this pin and to reset the chip.

 Most problems involve the clock.  Make sure the confi guration fuses are set to the proper 
oscillator setting.  In the above case, for a 10MHz crystal HS (High Speed) is the proper 
setting.  In the above circuit, the size of the resistor may need adjustment depending 
upon the crystal.

 If the program does not seem to be running, verify 5 Volts on the MCLR pin and the two 
power pins.

 Isolate hardware problems from fi rmware problems by running a program with the 
following at the start of main ( ) and check B0 with a logic probe or scope:
  while(TRUE)   {
   output_low (PIN_B0);
   delay_ms (1000);
   output_high (PIN_B0);
   delay_ms (1000);
  }

21 MIGRATING TO YOUR 
OWN HARDWARE

The following diagram is a somewhat minimal circuit for a PIC16F1937
 Notice this chip has two +5V and ground connections. Some chips have only one of 

each. A 0.1µf capacitor mounted near the chip is a good idea and one on either side of 
the chip is even better. This will reduce noise both to and from the chip.

 The clock circuit here uses a crystal. With many high speed crystals the resistor on 
clock out prevents the crystal from being driven. The capacitor values used are generally 
specifi ed in the crystal specifi cation sheets. The PIC16F1937 data sheet will show a 
number of other options for the clock.
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The In-Circuit Progamming/Debugging Interface
 To program and/or debug in circuit, two I/O pins (B6, B7) are reserved. If debugging is 

not to be done, then these pins may also be used in the target circuit. However, care 
must be taken to ensure the target circuit has high impedance during programming.

 The MCLR pin is also used by the programmer and for debugging. Note that during 
programming, the voltage on this is 13 volts. The 47K resistor to 5V is suffi cient isolation 
for the 13V. However, if anything else is connected to the MCLR pin, be sure the 13V will 
not damage or interfere.

 The ICD unit requires Vdd from the target. It is easiest to power up the target normally and 
then, connect the target board Vdd to the ICD for power. The ICD-S is powered by this pin 
(5V) and the ICD-U uses it to pull up the signals (3V-5V).

 The B3 pin is optional and is not used for programming. However, the monitor feature 
of the debugger does use B3. It is possible to program and debug (without monitor) and 
allocate B3 to the target hardware. In this case do not connect B3 to the ICD connector.

 Note that the ICD to target cable reverses the pins so the MCLR signal is ICD pin 6 and 
that connects to the target pin 1.

1  2  3  4  5  6

Vdd

Vdd

47K

MCLR

PGD (usually B7)
PGC (usually B6)
B3 (optional)

VSS

Target ICD connector
Looking into the connector

PIC
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This booklet is not intended to be a tutorial for the PIC16F1937 or the C programming 
language. It does attempt  to cover the basic use and operation of the development tools. 
There are some helpful tips and techniques covered, however, this is far from complete 
instruction on C programming. For the reader not using this as a part of a class and without 
prior C experience the following references should help. 

Exercise
PICmicro® MCU C: An introduction to 
Programming the Microchip PIC® in 

CCS by Nigel Gardner

The C Programming Language by 
Brian W. Kernighan and 

Dennis M. Ritchie (2nd ed.)
3 1.1 The structure of C Programs

1.2 Components of a C Program
1.3 main()
1.5 #include
1.8 constants
1.11 Macros
1.13 Hardware Compatibility
5.5 While loop
9.1 Inputs and Outputs

1.1 Getting Started
1.4 Symbolic Constants
3.1 Statements and Blockx
3.5 Loops
1.11 The C Preprocessor

4 1.7 Variables
1.10 Functions
2.1 Data Types
2.2 Variable Declaration
2.3 Variable Assignment
2.4 Enumeration
3.1 Functions
3.4 Using Function Arguments
4.2 Relational Operators
5.7 Nesting Program Control Statements
5.10 Switch Statement

1.2 Variables and Arithmetic Expr
2.1 Variable Names
2.2 Data Types and Sizes
2.3 Constants
2.4 Declarations
2.6 Relational and Logical Operators
3.4 Switch
1.7 Functions
1.8 Arguments
4.1 Basics of Functions

5 4.3 Logical Operators
4.4 Bitwise Operators
4.5 Increment and Decrement
5.1 if Statements
5.2 if-else Statements
9.3 Advanced BIT Manipulation

3.2 if-Else
2.8 Increment and Decrement Ops
2.90 Bitwise Operators

6 4.1 Arithmetic Operators 2.5 Arithmetic Operators

7 9.5 A/D Conversion 3.3 Else

References



8 5.4 For Loop
6.1 One-Dimensional Arrays

1.3 The For Statement
1.6 Arrays
2.10 Assignments Operators and 
Exp

10
1.6 printf Function
9.6 Data Comms/RS-232

1.5 Character Input and Output
2.6 Loops-Do-While
7.1 Standard Input and Output
7.2 Formatted Output - printf

11 6.2 Strings
6.4 Initializing Arrays
8.1 Introduction to Structures

7.9 Character Arrays
6.1 Basics of Structures
6.3 Arrays of Structures

13 9.4 Timers

14 2.6 Type Conversion
9.11 Interrupts

2.7 Type Conversions

16 9.8 SPI Communications
17 9.7 I2C Communications

18 5.2 ? Operator 2.11 Conditional Expressions
19 4.6 Precedence of Operators 2.12 Precedence and Order Eval

Comprehensive list of PICmicro® 
Development tools and information

www.mcuspace.com

Microchip Home Page www.microchip.com

CCS Compiler/Tools Home Page www.ccsinfo.com

CCS Compiler/Tools Software Update 
Page

www.ccsinfo.com
click: Support → Downloads

C Compiler User Message Exchange www.ccsinfo.com/forum

Device Datasheets List www.ccsinfo.com
click: Support → Device Datasheets

C Compiler Technical Support support@ccsinfo.com

On The Web



Other Development Tools

EMULATORS 
The ICD used in this booklet uses two I/O pins on the chip to communicate with a small 
debug program in the chip. This is a basic debug tool that takes up some of the chip’s 
resources (I/O pins and memory). An emulator replaces the chip with a special connector 
that connects to a unit that emulates the chip. The debugging works in a simulator manner 
except that the chip has all of its normal resources, the debugger runs faster and there are 
more debug features. For example an emulator typically will allow any number of breakpoints. 
Some of the emulators can break on an external event like some signal on the target board 
changing. Some emulators can break on an external event like some that were executed 
before a breakpoint was reached. Emulators cost between $500 and $3000 depending on the 
chips they cover and the features.

DEVICE PROGRAMMERS 
The ICD can be used to program FLASH chips as was done in these exercises. A stand 
alone device programmer may be used to program all the chips. These programmers will 
use the .HEX file output from the compiler to do the programming. Many standard EEPROM 
programmers do know how to program the Microchip parts. There are a large number of 
Microchip only device programmers in the $100-$200 price range. Note that some chips 
can be programmed once (OTP) and some parts need to be erased under a UV light before 
they can be re-programmed (Windowed). CCS offers the Mach X which is a stand-alone 
programmer and can be used as an in-circuit debugger.

PROTOTYPING BOARDS 
There are a large number of Prototyping boards available from a number of sources. 
Some have an ICD interface and others simply have a socket for a chip that is externally 
programmed.  Some boards have some advanced functionality on the board to help design 
complex software. For example, CCS has a Prototyping board with a full 56K modem on 
board and a TCP/IP stack chip ready to run internet applications such as an e-mail sending 
program or a mini web server. Another Prototyping board from CCS has a USB interface chip, 
making it easy to start developing USB application programs.

SIMULATORS 
A simulator is a program that runs on the PC and pretends to be a microcontroller chip. 
A simulator offers all the normal debug capability such as single stepping and looking at 
variables, however there is no interaction with real hardware. This works well if you want to 
test a math function but not so good if you want to test an interface to another chip. With the 
availability of low cost tools, such as the ICD in this kit, there is less interest in simulators. 
Microchip offers a free simulator that can be downloaded from their web site. Some other 
vendors offer simulators as a part of their development packages.



CCS Programmer Control Software

The CCSLOAD software will work for all the CCS device programmers and replaces the 
older ICD.EXE and MACHX.EXE software. The CCSLOAD software is stand-alone and 
does not require any other software on the PC. CCSLOAD supports ICD-Sxx, ICD-Uxx, 
Mach X, Load-n-Go, and PRIME8.

Powerful Command Line Options in Windows and Linux 
 · Specify operational settings at the execution level
 · Set-up software to perform, tasks like save, set target Vdd
 · Preset with operational or control settings for user
Easy to use Production Interface 
 · Simply point, click and program 
 · Additions to HEX file organization include associating comments or a graphic image  
   to a file to better ensure proper file selection for programming
 · Hands-Free mode auto programs each time a new target is connected to the programmer
 · PC audio cues indicate success and fail
Extensive Diagnostics 
 · Each target pin connection can be individually tested
 · Programming and debugging is tested with known good programs
 · Various PC driver tests to identify specific driver installation problems
Enhanced Security Options
 · Erase chips that failed programming
 · Verify protected code cannot be read after programming
 · File wide CRC checking
Automatic Serial Numbering Options
 · Program memory or Data EEPROM
 · Incremented, from a file list or by user prompt
 · Binary, ASCII string or UNICODE string
CCS IDE owners can use the CCSLOAD program with:
 · MPLAB®ICD 2/ICD 3
 · MPLAB®REAL ICE™
 · All CCS programmers and debuggers
How to Get Started:
Step 1: Connect Programmer to PC and target board.  Software will auto-detect the   
 programmer and device.
Step 2: Select Hex File for target board.  
Step 3: Select Test Target.  Status bar will show current progress of the operation.
Step 4: Click “Write to Chip” to program the device.

Use the Diagnostics tab for troubleshooting or the ccsload.chm help file for additional assistance.
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